aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingli Yu <Mingli.Yu@windriver.com>2019-02-26 10:50:25 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-02-28 17:47:03 +0000
commit5e66a6b4540e5e29f401f7490e9b3b2029ea94a5 (patch)
tree45c628845382e87beccc1882eb4f59b03fc0f5a9
parent00716a795f10e223150b0f9b214d185d654f4cc1 (diff)
downloadopenembedded-core-contrib-5e66a6b4540e5e29f401f7490e9b3b2029ea94a5.tar.gz
libdazzle: add check for GTK3DISTROFEATURES
When do world buid, there comes below error: | ERROR: Nothing PROVIDES 'gtk+3' (but /build/layers/oe-core/meta/recipes-gnome/libdazzle/libdazzle_3.30.2.bb DEPENDS on or otherwise requires it) | gtk+3 was skipped: one of 'x11 wayland' needs to be in DISTRO_FEATURES Add the check for GTK3DISTROFEATURES to make the world build work even without GTK3DISTROFEATURES. Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-gnome/libdazzle/libdazzle_3.30.2.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-gnome/libdazzle/libdazzle_3.30.2.bb b/meta/recipes-gnome/libdazzle/libdazzle_3.30.2.bb
index 5441c10f99..3779b15af9 100644
--- a/meta/recipes-gnome/libdazzle/libdazzle_3.30.2.bb
+++ b/meta/recipes-gnome/libdazzle/libdazzle_3.30.2.bb
@@ -3,7 +3,7 @@ LICENSE = "GPLv3+"
LIC_FILES_CHKSUM = "file://COPYING;md5=8f0e2cd40e05189ec81232da84bd6e1a"
GNOMEBASEBUILDCLASS = "meson"
-inherit gnomebase upstream-version-is-even vala gobject-introspection
+inherit gnomebase upstream-version-is-even vala distro_features_check gobject-introspection
DEPENDS = "glib-2.0-native glib-2.0 gtk+3"
@@ -14,5 +14,7 @@ SRC_URI[archive.sha256sum] = "78770eae9fa15ac5acb9c733d29459330b2540affbf7293311
GI_ENABLE_FLAG = "-Dwith_introspection=true"
GI_DISABLE_FLAG = "-Dwith_introspection=false"
+ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
+
EXTRA_OEMESON_append_class-target = " ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '${GI_ENABLE_FLAG}', \
'${GI_DISABLE_FLAG}', d)} "