aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelipe F. Tonello <eu@felipetonello.com>2016-07-15 17:36:32 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-20 10:24:55 +0100
commit2db2724c4386fc07bd667060eb12b479747e0d35 (patch)
treec7d557098f0e9e1cf13734020ee26d81e8ef1a50
parentc6f24481b2fc965eeebca5508d68f1b9e5b3f212 (diff)
downloadopenembedded-core-contrib-2db2724c4386fc07bd667060eb12b479747e0d35.tar.gz
recipes-graphics: Added native and nativesdk support for some libraries
These libraries are used in some recipes outside oe-core, so we should add this class support to avoid duplication and bbappends on other layers. Signed-off-by: Felipe F. Tonello <eu@felipetonello.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-graphics/freetype/freetype_2.6.5.bb2
-rw-r--r--meta/recipes-graphics/xorg-lib/libxcursor_1.1.14.bb2
-rw-r--r--meta/recipes-graphics/xorg-lib/libxinerama_1.1.3.bb2
-rw-r--r--meta/recipes-graphics/xorg-proto/xineramaproto_1.2.1.bb2
4 files changed, 6 insertions, 2 deletions
diff --git a/meta/recipes-graphics/freetype/freetype_2.6.5.bb b/meta/recipes-graphics/freetype/freetype_2.6.5.bb
index b8cac1c5c3..97dde3a626 100644
--- a/meta/recipes-graphics/freetype/freetype_2.6.5.bb
+++ b/meta/recipes-graphics/freetype/freetype_2.6.5.bb
@@ -46,4 +46,4 @@ do_install_append() {
BINCONFIG = "${bindir}/freetype-config"
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-graphics/xorg-lib/libxcursor_1.1.14.bb b/meta/recipes-graphics/xorg-lib/libxcursor_1.1.14.bb
index a8e4f24b6b..17629047b7 100644
--- a/meta/recipes-graphics/xorg-lib/libxcursor_1.1.14.bb
+++ b/meta/recipes-graphics/xorg-lib/libxcursor_1.1.14.bb
@@ -12,7 +12,7 @@ LICENSE = "MIT-style"
LIC_FILES_CHKSUM = "file://COPYING;md5=8902e6643f7bcd7793b23dcd5d8031a4"
DEPENDS += "libxrender libxfixes"
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"
PE = "1"
diff --git a/meta/recipes-graphics/xorg-lib/libxinerama_1.1.3.bb b/meta/recipes-graphics/xorg-lib/libxinerama_1.1.3.bb
index 027c8043d8..bb03f44e25 100644
--- a/meta/recipes-graphics/xorg-lib/libxinerama_1.1.3.bb
+++ b/meta/recipes-graphics/xorg-lib/libxinerama_1.1.3.bb
@@ -18,3 +18,5 @@ XORG_PN = "libXinerama"
SRC_URI[md5sum] = "9336dc46ae3bf5f81c247f7131461efd"
SRC_URI[sha256sum] = "7a45699f1773095a3f821e491cbd5e10c887c5a5fce5d8d3fced15c2ff7698e2"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-graphics/xorg-proto/xineramaproto_1.2.1.bb b/meta/recipes-graphics/xorg-proto/xineramaproto_1.2.1.bb
index d00774ece5..dde7e9db7a 100644
--- a/meta/recipes-graphics/xorg-proto/xineramaproto_1.2.1.bb
+++ b/meta/recipes-graphics/xorg-proto/xineramaproto_1.2.1.bb
@@ -15,3 +15,5 @@ PE = "1"
SRC_URI[md5sum] = "9959fe0bfb22a0e7260433b8d199590a"
SRC_URI[sha256sum] = "977574bb3dc192ecd9c55f59f991ec1dff340be3e31392c95deff423da52485b"
+
+BBCLASSEXTEND = "native nativesdk"