aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-07-11 17:33:53 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-20 10:24:51 +0100
commit15390ec8600055964642c87aadb94e8457c3e1b6 (patch)
tree56b7b9310562273a4380a01a9c950162a30f285d
parent4d564091b9f24767e36d7b635cce7c5ba9c61ae3 (diff)
downloadopenembedded-core-contrib-15390ec8600055964642c87aadb94e8457c3e1b6.tar.gz
recipes-sato: fix upstream version check
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-sato/matchbox-config-gtk/matchbox-config-gtk_0.2.bb1
-rw-r--r--meta/recipes-sato/matchbox-terminal/matchbox-terminal_0.1.bb1
-rw-r--r--meta/recipes-sato/matchbox-theme-sato/matchbox-theme-sato_0.2.bb1
-rw-r--r--meta/recipes-sato/sato-screenshot/sato-screenshot_0.2.bb1
-rw-r--r--meta/recipes-sato/settings-daemon/settings-daemon_0.0.2.bb1
5 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-sato/matchbox-config-gtk/matchbox-config-gtk_0.2.bb b/meta/recipes-sato/matchbox-config-gtk/matchbox-config-gtk_0.2.bb
index 3ca5989944..b993a94547 100644
--- a/meta/recipes-sato/matchbox-config-gtk/matchbox-config-gtk_0.2.bb
+++ b/meta/recipes-sato/matchbox-config-gtk/matchbox-config-gtk_0.2.bb
@@ -13,6 +13,7 @@ RDEPENDS_${PN} = "settings-daemon"
SRCREV = "ef2192ce98d9374ffdad5f78544c3f8f353c16aa"
SRC_URI = "git://git.yoctoproject.org/${BPN} \
file://no-handed.patch"
+UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))"
S = "${WORKDIR}/git"
diff --git a/meta/recipes-sato/matchbox-terminal/matchbox-terminal_0.1.bb b/meta/recipes-sato/matchbox-terminal/matchbox-terminal_0.1.bb
index e0a899cb5b..4488191b23 100644
--- a/meta/recipes-sato/matchbox-terminal/matchbox-terminal_0.1.bb
+++ b/meta/recipes-sato/matchbox-terminal/matchbox-terminal_0.1.bb
@@ -12,6 +12,7 @@ SECTION = "x11/utils"
#SRCREV tagged 0.1
SRCREV = "3ad357db2302760b8a8817b5f4478dd87479442f"
SRC_URI = "git://git.yoctoproject.org/${BPN}"
+UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))"
S = "${WORKDIR}/git"
diff --git a/meta/recipes-sato/matchbox-theme-sato/matchbox-theme-sato_0.2.bb b/meta/recipes-sato/matchbox-theme-sato/matchbox-theme-sato_0.2.bb
index 8fc6bb3363..7a043d3447 100644
--- a/meta/recipes-sato/matchbox-theme-sato/matchbox-theme-sato_0.2.bb
+++ b/meta/recipes-sato/matchbox-theme-sato/matchbox-theme-sato_0.2.bb
@@ -3,5 +3,6 @@ require matchbox-theme-sato.inc
# SRCREV tagged 0.2
SRCREV = "df085ba9cdaeaf2956890b0e29d7ea1779bf6c78"
SRC_URI = "git://git.yoctoproject.org/matchbox-sato"
+UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))"
S = "${WORKDIR}/git"
diff --git a/meta/recipes-sato/sato-screenshot/sato-screenshot_0.2.bb b/meta/recipes-sato/sato-screenshot/sato-screenshot_0.2.bb
index 92f0ee17db..ff91746ebe 100644
--- a/meta/recipes-sato/sato-screenshot/sato-screenshot_0.2.bb
+++ b/meta/recipes-sato/sato-screenshot/sato-screenshot_0.2.bb
@@ -12,6 +12,7 @@ DEPENDS = "matchbox-panel-2 gtk+3"
# SRCREV tagged 0.2
SRCREV = "5db2672fb857b2c80b949d8fce92e0f0029cc947"
SRC_URI = "git://git.yoctoproject.org/screenshot"
+UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))"
S = "${WORKDIR}/git"
diff --git a/meta/recipes-sato/settings-daemon/settings-daemon_0.0.2.bb b/meta/recipes-sato/settings-daemon/settings-daemon_0.0.2.bb
index 56eb656ecb..ceaeccaaa1 100644
--- a/meta/recipes-sato/settings-daemon/settings-daemon_0.0.2.bb
+++ b/meta/recipes-sato/settings-daemon/settings-daemon_0.0.2.bb
@@ -13,6 +13,7 @@ SRC_URI = "git://git.yoctoproject.org/xsettings-daemon \
file://addsoundkeys.patch;apply=yes \
file://70settings-daemon.sh \
"
+UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))"
S = "${WORKDIR}/git"