aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Lamego <jose.a.lamego@linux.intel.com>2016-12-15 16:44:45 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-12-17 09:56:45 +0000
commitc9c54f352c5122b9a4239f69779400e3ba250827 (patch)
treeabcfae5bf9954a3f93b86652ffb256861ea7470b
parent1d50e11286722c4114c1ae0bc285f846cd85fc4c (diff)
downloadopenembedded-core-contrib-c9c54f352c5122b9a4239f69779400e3ba250827.tar.gz
python*-git: Upgrade to version 2.1.1
Both python-git and python3-git need to be upgraded to latest upstream version. This change includes python3 dependencies added and was tested using qemux86 with core-image-sato. Signed-off-by: Jose Lamego <jose.a.lamego@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/python/python-git.inc4
-rw-r--r--meta/recipes-devtools/python/python-git_2.1.1.bb (renamed from meta/recipes-devtools/python/python-git_2.1.0.bb)0
-rw-r--r--meta/recipes-devtools/python/python3-git_2.1.1.bb (renamed from meta/recipes-devtools/python/python3-git_2.1.0.bb)2
3 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-devtools/python/python-git.inc b/meta/recipes-devtools/python/python-git.inc
index ad41561ad2..feddf275b9 100644
--- a/meta/recipes-devtools/python/python-git.inc
+++ b/meta/recipes-devtools/python/python-git.inc
@@ -10,8 +10,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=8b8d26c37c1d5a04f9b0186edbebc183"
SRC_URI = "https://files.pythonhosted.org/packages/source/G/GitPython/GitPython-${PV}.tar.gz"
-SRC_URI[md5sum] = "29b1fcf504d080dc7a5e630957e829d7"
-SRC_URI[sha256sum] = "3ebda1e6ff1ef68597e41dcd1b99c2a5ae902f4dc2b22ad3533cc89c32b42aad"
+SRC_URI[md5sum] = "77f8339e68dedb6d7c4e26371a588ed9"
+SRC_URI[sha256sum] = "e96f8e953cf9fee0a7599fc587667591328760b6341a0081ef311a942fc96204"
UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/GitPython/"
UPSTREAM_CHECK_REGEX = "/GitPython/(?P<pver>(\d+[\.\-_]*)+)"
diff --git a/meta/recipes-devtools/python/python-git_2.1.0.bb b/meta/recipes-devtools/python/python-git_2.1.1.bb
index e49dbea544..e49dbea544 100644
--- a/meta/recipes-devtools/python/python-git_2.1.0.bb
+++ b/meta/recipes-devtools/python/python-git_2.1.1.bb
diff --git a/meta/recipes-devtools/python/python3-git_2.1.0.bb b/meta/recipes-devtools/python/python3-git_2.1.1.bb
index c9fe9baa20..7a2d452a24 100644
--- a/meta/recipes-devtools/python/python3-git_2.1.0.bb
+++ b/meta/recipes-devtools/python/python3-git_2.1.1.bb
@@ -4,4 +4,4 @@ DEPENDS = "python3-gitdb"
inherit setuptools3
-RDEPENDS_${PN} += "python3-gitdb python3-lang python3-io python3-shell python3-math python3-re python3-subprocess python3-stringold python3-unixadmin python3-enum python3-logging python3-datetime python3-netclient"
+RDEPENDS_${PN} += "python3-gitdb python3-lang python3-io python3-shell python3-math python3-re python3-subprocess python3-stringold python3-unixadmin python3-enum python3-logging python3-datetime python3-netclient python3-unittest python3-argparse"