aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-09-06 12:15:19 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-09-06 23:43:34 +0100
commit561577add4b935d9bfb7b7dd6abdc3e26c1d9143 (patch)
tree3f8d55212bc10f46685e2ebc42a2c81d10e83a14
parent231e13c76d3ca7beebfbc8d8a856f72fa3780601 (diff)
downloadopenembedded-core-contrib-561577add4b935d9bfb7b7dd6abdc3e26c1d9143.tar.gz
python3: trim PGO patch
There's no need to delete the line that removes the profile data, as we're not using it after the build. This reduces the size of the patch, making it easier to maintain. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python3/0002-Makefile-add-target-to-split-profile-generation.patch4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/python/python3/0002-Makefile-add-target-to-split-profile-generation.patch b/meta/recipes-devtools/python/python3/0002-Makefile-add-target-to-split-profile-generation.patch
index bb01c5bcb4..2b4ba316e4 100644
--- a/meta/recipes-devtools/python/python3/0002-Makefile-add-target-to-split-profile-generation.patch
+++ b/meta/recipes-devtools/python/python3/0002-Makefile-add-target-to-split-profile-generation.patch
@@ -19,7 +19,7 @@ diff --git a/Makefile.pre.in b/Makefile.pre.in
index 84bc3ff..017a2c4 100644
--- a/Makefile.pre.in
+++ b/Makefile.pre.in
-@@ -469,13 +469,11 @@ profile-opt:
+@@ -469,13 +469,12 @@ profile-opt:
$(MAKE) profile-removal
$(MAKE) build_all_generate_profile
$(MAKE) profile-removal
@@ -31,7 +31,7 @@ index 84bc3ff..017a2c4 100644
@echo "Rebuilding with profile guided optimizations:"
$(MAKE) clean
$(MAKE) build_all_use_profile
-- $(MAKE) profile-removal
+ $(MAKE) profile-removal
build_all_generate_profile:
$(MAKE) @DEF_MAKE_RULE@ CFLAGS_NODIST="$(CFLAGS) $(EXTRA_CFLAGS) $(PGO_PROF_GEN_FLAG) @LTOFLAGS@" LDFLAGS="$(LDFLAGS) $(PGO_PROF_GEN_FLAG) @LTOFLAGS@" LIBS="$(LIBS)"