summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2016-04-05 15:46:21 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-04-05 15:47:43 +0100
commitdbae075f62ecceadacc6d847e5697b9f3339b168 (patch)
treed13d753acbe302bd00f8d9252c7e6d034a3cc088
parent773e9ef9bacbf1e63fe758915d599d11762b8c1f (diff)
downloadopenembedded-core-contrib-dbae075f62ecceadacc6d847e5697b9f3339b168.tar.gz
openembedded-core-contrib-dbae075f62ecceadacc6d847e5697b9f3339b168.tar.bz2
openembedded-core-contrib-dbae075f62ecceadacc6d847e5697b9f3339b168.zip
sanity: Increase minimum git version to 1.8.3.1
The kernel tools assume git > 1.7.9.5, I'm unsure of the exact version but the oldest in our infrastructure is 1.8.3.1. The git fetcher also currently has nasty workarounds for git < 1.7.9.2. Moving to 1.8.3.1 as our minimum version seems sane at this point as the oldest we're testing/supporting. [YOCTO #6162] Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/classes/sanity.bbclass6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta/classes/sanity.bbclass b/meta/classes/sanity.bbclass
index 662f764533..d229938c93 100644
--- a/meta/classes/sanity.bbclass
+++ b/meta/classes/sanity.bbclass
@@ -531,14 +531,16 @@ def check_tar_version(sanity_data):
return None
# We use git parameters and functionality only found in 1.7.8 or later
+# The kernel tools assume git >= 1.8.3.1 (verified needed > 1.7.9.5) see #6162
+# The git fetcher also had workarounds for git < 1.7.9.2 which we've dropped
def check_git_version(sanity_data):
from distutils.version import LooseVersion
status, result = oe.utils.getstatusoutput("git --version 2> /dev/null")
if status != 0:
return "Unable to execute git --version, exit code %s\n" % status
version = result.split()[2]
- if LooseVersion(version) < LooseVersion("1.7.8"):
- return "Your version of git is older than 1.7.8 and has bugs which will break builds. Please install a newer version of git.\n"
+ if LooseVersion(version) < LooseVersion("1.8.3.1"):
+ return "Your version of git is older than 1.8.3.1 and has bugs which will break builds. Please install a newer version of git.\n"
return None
# Check the required perl modules which may not be installed by default