aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2018-12-17 10:26:48 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-12-18 16:19:29 +0000
commit863e520059cdc96817ec87983d1e036f291bf37c (patch)
treec93e232785ea5806cecabcd5130c316eeaf3722a
parentc4e273f6a2213ac898fbc504b9bfc12af633c9b8 (diff)
downloadopenembedded-core-contrib-863e520059cdc96817ec87983d1e036f291bf37c.tar.gz
linux-yocto: correct qemumips64el definition
The big endian mips definition was used as the basis for the little endian machine. Unfortunatey, the KMACHINE definitions were not fully cleared, so big endian builds will match on the 'le' variant .. and break. We drop the BE machine definitions from the LE variant and we are fixed. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.18.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.19.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.19.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.18.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.19.bb2
6 files changed, 6 insertions, 6 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.18.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.18.bb
index ae620f578f..bc28e1c021 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.18.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.18.bb
@@ -12,7 +12,7 @@ python () {
}
SRCREV_machine ?= "6228ee37a46479d624e608c572d241f74eee11b6"
-SRCREV_meta ?= "cc2fb5bd0e71f4beec5c4ce726da0a87e2d55337"
+SRCREV_meta ?= "8f4a98c93851f7f83d796aae2871df2798b8d917"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.18;destsuffix=${KMETA}"
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.19.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.19.bb
index ffdebec73b..cdcdff2e17 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.19.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.19.bb
@@ -12,7 +12,7 @@ python () {
}
SRCREV_machine ?= "bd456d13d8bea4c416209a59f9e0bf50f8511c47"
-SRCREV_meta ?= "1992fb4dad3012f71d319273d61da22ed9aa0469"
+SRCREV_meta ?= "ced14887c323f1cb6b3befe2b29e471e8fee1bc6"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.19;destsuffix=${KMETA}"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb
index 24a12fc052..b2ca264987 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb
@@ -17,7 +17,7 @@ KCONF_BSP_AUDIT_LEVEL = "2"
SRCREV_machine_qemuarm ?= "bd4312baf01b5aca2745245c3856b5143bf0c6ad"
SRCREV_machine ?= "9eddc793f95f4e7e283996a007e205622c633539"
-SRCREV_meta ?= "cc2fb5bd0e71f4beec5c4ce726da0a87e2d55337"
+SRCREV_meta ?= "8f4a98c93851f7f83d796aae2871df2798b8d917"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.19.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.19.bb
index 8f6e993d6d..89c4b9f14d 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.19.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.19.bb
@@ -17,7 +17,7 @@ KCONF_BSP_AUDIT_LEVEL = "2"
SRCREV_machine_qemuarm ?= "b8f2e8e00f8ddbdf5d7d7614c14eab52f8ee9275"
SRCREV_machine ?= "e727c70583a78cf1dc53e8e219722e2f9d1bc858"
-SRCREV_meta ?= "1992fb4dad3012f71d319273d61da22ed9aa0469"
+SRCREV_meta ?= "ced14887c323f1cb6b3befe2b29e471e8fee1bc6"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.18.bb b/meta/recipes-kernel/linux/linux-yocto_4.18.bb
index 94f2c9c473..96c89723e6 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.18.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.18.bb
@@ -19,7 +19,7 @@ SRCREV_machine_qemux86 ?= "9eddc793f95f4e7e283996a007e205622c633539"
SRCREV_machine_qemux86-64 ?= "9eddc793f95f4e7e283996a007e205622c633539"
SRCREV_machine_qemumips64 ?= "6641acbf076ba3f7ad96e846581272215a537904"
SRCREV_machine ?= "9eddc793f95f4e7e283996a007e205622c633539"
-SRCREV_meta ?= "cc2fb5bd0e71f4beec5c4ce726da0a87e2d55337"
+SRCREV_meta ?= "8f4a98c93851f7f83d796aae2871df2798b8d917"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;name=machine;branch=${KBRANCH}; \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.18;destsuffix=${KMETA}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.19.bb b/meta/recipes-kernel/linux/linux-yocto_4.19.bb
index 9b998c75e5..bf4fec71d8 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.19.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.19.bb
@@ -19,7 +19,7 @@ SRCREV_machine_qemux86 ?= "e727c70583a78cf1dc53e8e219722e2f9d1bc858"
SRCREV_machine_qemux86-64 ?= "e727c70583a78cf1dc53e8e219722e2f9d1bc858"
SRCREV_machine_qemumips64 ?= "d21ff98864241c971c7a42a3c4f1eb940b9b8855"
SRCREV_machine ?= "e727c70583a78cf1dc53e8e219722e2f9d1bc858"
-SRCREV_meta ?= "1992fb4dad3012f71d319273d61da22ed9aa0469"
+SRCREV_meta ?= "ced14887c323f1cb6b3befe2b29e471e8fee1bc6"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;name=machine;branch=${KBRANCH}; \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.19;destsuffix=${KMETA}"