summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDexuan Cui <dexuan.cui@intel.com>2011-04-15 16:40:47 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-04-18 05:43:23 +0100
commitdf818bd36864ba515aeeec0c5314d174313c03a3 (patch)
treedd1740bf445bd5341563d8330dd58811c9079c34
parent8ecc3d053c281336a653ee487a3425ada602faaf (diff)
downloadopenembedded-core-contrib-df818bd36864ba515aeeec0c5314d174313c03a3.tar.gz
libnewt: fix parallel-make issue
Add patch to remove hardcoded /usr/include/slang Fixes [YOCTO #947] Signed-off-by: Dexuan Cui <dexuan.cui@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-extended/newt/files/fix_SHAREDDIR.patch29
-rw-r--r--meta/recipes-extended/newt/files/include-without-python.patch2
-rw-r--r--meta/recipes-extended/newt/files/remove_slang_include.patch13
-rw-r--r--meta/recipes-extended/newt/libnewt_0.52.12.bb8
4 files changed, 50 insertions, 2 deletions
diff --git a/meta/recipes-extended/newt/files/fix_SHAREDDIR.patch b/meta/recipes-extended/newt/files/fix_SHAREDDIR.patch
new file mode 100644
index 0000000000..7795260388
--- /dev/null
+++ b/meta/recipes-extended/newt/files/fix_SHAREDDIR.patch
@@ -0,0 +1,29 @@
+Upstream-Status: Pending
+
+Author: dexuan.cui@intel.com
+Date: Fri Apr 15 16:17:39 CST 2011
+
+The patch fixes a parallel-make issue: when generating $(SHAREDDIR)/%.o, we should
+ensure the directory ${SHAREDDIR} exists.
+
+We need to push the patch to upstream.
+
+Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -114,12 +114,12 @@
+
+ sharedlib: $(LIBNEWTSH)
+
+-$(LIBNEWTSH): $(SHAREDDIR) $(SHAREDOBJS)
++$(LIBNEWTSH): $(SHAREDOBJS)
+ $(CC) -shared -o $(LIBNEWTSH) $(SHLIBFLAGS) $(SHAREDOBJS) $(LDFLAGS) $(LIBS)
+ ln -fs $(LIBNEWTSONAME) libnewt.so
+ ln -fs $(LIBNEWTSH) $(LIBNEWTSONAME)
+
+-$(SHAREDDIR)/%.o : %.c
++$(SHAREDDIR)/%.o : %.c $(SHAREDDIR)
+ $(CC) $(SHCFLAGS) -c $(CFLAGS) $(CPPFLAGS) -o $@ $<
+
+ install: $(LIBNEWT) install-sh whiptail
diff --git a/meta/recipes-extended/newt/files/include-without-python.patch b/meta/recipes-extended/newt/files/include-without-python.patch
index 277ee3324d..263e9de039 100644
--- a/meta/recipes-extended/newt/files/include-without-python.patch
+++ b/meta/recipes-extended/newt/files/include-without-python.patch
@@ -1,3 +1,5 @@
+Upstream-Status: Pending
+
From 3d13bbbb769050fac4cc6c904c174edc27e4f03d Mon Sep 17 00:00:00 2001
From: Otavio Salvador <otavio@ossystems.com.br>
Date: Thu, 20 Jan 2011 14:14:51 -0200
diff --git a/meta/recipes-extended/newt/files/remove_slang_include.patch b/meta/recipes-extended/newt/files/remove_slang_include.patch
new file mode 100644
index 0000000000..dbdeef0901
--- /dev/null
+++ b/meta/recipes-extended/newt/files/remove_slang_include.patch
@@ -0,0 +1,13 @@
+Index: git/Makefile.in
+===================================================================
+--- git.orig/Makefile.in
++++ git/Makefile.in
+@@ -5,7 +5,7 @@ CC = @CC@
+ CPP = @CPP@
+ CFLAGS = @CFLAGS@
+ LDFLAGS = @LDFLAGS@
+-CPPFLAGS = -D_GNU_SOURCE -I/usr/include/slang @CPPFLAGS@
++CPPFLAGS = -D_GNU_SOURCE @CPPFLAGS@
+ GNU_LD = @GNU_LD@
+
+ VERSION = @VERSION@
diff --git a/meta/recipes-extended/newt/libnewt_0.52.12.bb b/meta/recipes-extended/newt/libnewt_0.52.12.bb
index eefd6bdfd9..e2ad55964d 100644
--- a/meta/recipes-extended/newt/libnewt_0.52.12.bb
+++ b/meta/recipes-extended/newt/libnewt_0.52.12.bb
@@ -17,11 +17,15 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
# slang needs to be >= 2.2
DEPENDS = "slang popt"
-PR = "r0"
+PR = "r2"
SRCREV = "c3c7be75f6ef1adfc2be5f99c1e8ef3f0ab58c38"
+
SRC_URI = "git://git.fedorahosted.org/git/newt;protocol=git \
- file://include-without-python.patch"
+ file://include-without-python.patch \
+ file://remove_slang_include.patch \
+ file://fix_SHAREDDIR.patch"
+
S = "${WORKDIR}/git"
EXTRA_OECONF = "--without-python --without-tcl"