summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-04-10 18:20:45 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-13 22:28:36 +0100
commit92be71296e1b7ed1e6387ae381942072aa3bb4f3 (patch)
treedefee7d4e45aed1a83ac8f8f2980df528011ab0f
parenta583f81d9bc6ae984699d9aba7a53019ff0afc23 (diff)
downloadopenembedded-core-contrib-92be71296e1b7ed1e6387ae381942072aa3bb4f3.tar.gz
xserver-xf86-config: Preload graphics driver modules for musl
musl does not support BIND_LAZY intentionally, which means dlopen will always complain about missing symbols which is what X does when loading graphics drivers, here we preload the needed drivers for all emulator machines if libc is musl Change-Id: I908c94c30db8a5e872922e1a677126d82fa17145 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/xorg-xserver/xserver-xf86-config/10-preload-modules.conf9
-rw-r--r--meta/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bb9
2 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-xserver/xserver-xf86-config/10-preload-modules.conf b/meta/recipes-graphics/xorg-xserver/xserver-xf86-config/10-preload-modules.conf
new file mode 100644
index 0000000000..7ceb6fd634
--- /dev/null
+++ b/meta/recipes-graphics/xorg-xserver/xserver-xf86-config/10-preload-modules.conf
@@ -0,0 +1,9 @@
+Section "Module"
+ Load "fbdevhw"
+ Load "fb"
+ Load "shadow"
+ Load "shadowfb"
+ Load "vbe"
+ Load "vgahw"
+EndSection
+
diff --git a/meta/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bb b/meta/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bb
index 5420b7d23e..e07c204c74 100644
--- a/meta/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bb
+++ b/meta/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bb
@@ -7,9 +7,14 @@ PR = "r33"
SRC_URI = "file://xorg.conf"
+SRC_URI_append_libc-musl = "\
+ file://10-preload-modules.conf \
+"
+
S = "${WORKDIR}"
CONFFILES_${PN} = "${sysconfdir}/X11/xorg.conf"
+CONFFILES_${PN}_append_libc-musl = " ${sysconfdir}/X11/xorg.conf.d/10-preload-modules.conf"
PACKAGE_ARCH = "${MACHINE_ARCH}"
ALLOW_EMPTY_${PN} = "1"
@@ -20,3 +25,7 @@ do_install () {
install -m 0644 ${WORKDIR}/xorg.conf ${D}/${sysconfdir}/X11/
fi
}
+
+do_install_append_libc-musl () {
+ install -Dm 0644 ${WORKDIR}/10-preload-modules.conf ${D}/${sysconfdir}/X11/xorg.conf.d/10-preload-modules.conf
+}