aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDengke Du <dengke.du@windriver.com>2016-04-25 22:59:19 -0700
committerRobert Yang <liezhi.yang@windriver.com>2016-04-26 18:08:53 -0700
commitc4fd337802c3bba5b1b9a8e1b4ee7ea538c363dc (patch)
tree39452f2b33a985c32e59edb30e249fd2e0f950e7
parente2dbe5eb869b8336b91023b83d7ca866197efa73 (diff)
downloadopenembedded-core-contrib-c4fd337802c3bba5b1b9a8e1b4ee7ea538c363dc.tar.gz
coreutils: fix for native and nativesdkrbt/core
The do_install_append is used for moving/renaming for ALTERNATIVE, but it breaks native, for example there is no ln, but ln.coreutils, that makes coreutils-native don't work. This patch fixes the problem. Signed-off-by: Dengke Du <dengke.du@windriver.com> Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta/recipes-core/coreutils/coreutils_8.25.bb14
1 files changed, 9 insertions, 5 deletions
diff --git a/meta/recipes-core/coreutils/coreutils_8.25.bb b/meta/recipes-core/coreutils/coreutils_8.25.bb
index 419a693372..b1aaf539fb 100644
--- a/meta/recipes-core/coreutils/coreutils_8.25.bb
+++ b/meta/recipes-core/coreutils/coreutils_8.25.bb
@@ -69,6 +69,15 @@ do_compile_prepend () {
mkdir -p ${B}/src
}
+do_install_class-native() {
+ autotools_do_install
+ # remove groups to fix conflict with shadow-native
+ rm -f ${D}${STAGING_BINDIR_NATIVE}/groups
+ # The return is a must since native doesn't need the
+ # do_install_append() in the below.
+ return
+}
+
do_install_append() {
for i in df mktemp base64; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${BPN}; done
@@ -91,11 +100,6 @@ do_install_append() {
cp -a ${D}${mandir}/man1/test.1 ${D}${mandir}/man1/lbracket.1.${BPN}
}
-do_install_append_class-native(){
- # remove groups to fix conflict with shadow-native
- rm -f ${D}${STAGING_BINDIR_NATIVE}/groups
-}
-
inherit update-alternatives
ALTERNATIVE_PRIORITY = "100"