aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2018-12-16 22:38:17 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-12-18 16:19:29 +0000
commitbd066bf4aa47b6ca37fbeb4ac4909d75a8a1e285 (patch)
tree28c11b32a94db3b987622e6de4f6fb6b6d571ab4
parentdc11aab60e7561d764c56808277b47e7bb40c6c0 (diff)
downloadopenembedded-core-contrib-bd066bf4aa47b6ca37fbeb4ac4909d75a8a1e285.tar.gz
linux-yocto/tiny: restore qemuarm support
qemuarm-tiny support was added to the 4.15 linux-yocto kernel, and was incorrectly dropped from 4.18. This restores the support for out of the box builds in 4.18+. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb
index bb31d3dd66..968b94c207 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb
@@ -1,4 +1,6 @@
KBRANCH ?= "v4.18/standard/tiny/base"
+KBRANCH_qemuarm ?= "v4.15/standard/tiny/arm-versatile-926ejs"
+
LINUX_KERNEL_TYPE = "tiny"
KCONFIG_MODE = "--allnoconfig"
@@ -13,6 +15,7 @@ DEPENDS += "openssl-native util-linux-native"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
+SRCREV_machine_qemuarm ?= "33859b3077c83d8a024946ba06a59990546fcbc7"
SRCREV_machine ?= "33859b3077c83d8a024946ba06a59990546fcbc7"
SRCREV_meta ?= "e39413ec2bdda10cdfb7e7e4df228be8d39e6639"
@@ -21,7 +24,7 @@ PV = "${LINUX_VERSION}+git${SRCPV}"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.18;destsuffix=${KMETA}"
-COMPATIBLE_MACHINE = "qemux86|qemux86-64"
+COMPATIBLE_MACHINE = "qemux86|qemux86-64|qemuarm"
# Functionality flags
KERNEL_FEATURES = ""