aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2015-08-19 11:51:04 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-24 23:43:24 +0100
commit1f7aaf76f4aa7875f05f4b838a5ec4594a4c35dc (patch)
treeba09a8acd462f99d1a68b25a23c3293aafa0a11a
parent14052535a8d5f137e22439f33aad73bc4b777d58 (diff)
downloadopenembedded-core-contrib-1f7aaf76f4aa7875f05f4b838a5ec4594a4c35dc.tar.gz
openssh: build regression test binaries
ptests were failing and many more were being silently skipped because required binaries were not being built. Build the binaries in regress/ and set SUDO environment variable in run-ptests: after this all tests in regress/ are now run. Continue to skip building binaries in regress/unittests/: unittest runtime is excessive. On a NUC running intel-corei7-64 core-image-sato, new results are: PASS: 55, SKIP: 3, FAIL: 0 [YOCTO #8153] Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rwxr-xr-xmeta/recipes-connectivity/openssh/openssh/run-ptest2
-rw-r--r--meta/recipes-connectivity/openssh/openssh_7.0p1.bb6
2 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-connectivity/openssh/openssh/run-ptest b/meta/recipes-connectivity/openssh/openssh/run-ptest
index 3e725cf282..564c0c8256 100755
--- a/meta/recipes-connectivity/openssh/openssh/run-ptest
+++ b/meta/recipes-connectivity/openssh/openssh/run-ptest
@@ -3,5 +3,5 @@
export TEST_SHELL=sh
cd regress
-make -k .OBJDIR=`pwd` .CURDIR=`pwd` tests \
+make -k .OBJDIR=`pwd` .CURDIR=`pwd` SUDO="sudo" tests \
| sed -e 's/^skipped/SKIP: /g' -e 's/^ok /PASS: /g' -e 's/^failed/FAIL: /g'
diff --git a/meta/recipes-connectivity/openssh/openssh_7.0p1.bb b/meta/recipes-connectivity/openssh/openssh_7.0p1.bb
index 105875a60d..67abe577b5 100644
--- a/meta/recipes-connectivity/openssh/openssh_7.0p1.bb
+++ b/meta/recipes-connectivity/openssh/openssh_7.0p1.bb
@@ -79,6 +79,12 @@ do_configure_prepend () {
fi
}
+do_compile_ptest() {
+ # skip regress/unittests/ binaries: this will silently skip
+ # unittests in run-ptests which is good because they are so slow.
+ oe_runmake regress/modpipe regress/setuid-allowed regress/netcat
+}
+
do_install_append () {
if [ "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}" = "pam" ]; then
install -D -m 0755 ${WORKDIR}/sshd ${D}${sysconfdir}/pam.d/sshd