summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2019-09-26 10:51:43 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-09-27 13:01:17 +0100
commitbd8ba628b0ff1ad3603b08981467edf5e36ec024 (patch)
tree6252d983f46bc34d9dc9b7e3f6e0b903a6c6f2b6
parent0217a0392b8cc534fcc0d760b7663a1845b306f5 (diff)
downloadopenembedded-core-contrib-bd8ba628b0ff1ad3603b08981467edf5e36ec024.tar.gz
expect: Fix configure error for nativesdk
Fixed: $ bitbake nativesdk-expect checking for Tcl public headers... configure: error: tcl.h not found. Please specify its location with --with-tclinclude Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/expect/expect_5.45.4.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-devtools/expect/expect_5.45.4.bb b/meta/recipes-devtools/expect/expect_5.45.4.bb
index 96eacd9293..5f59083ad2 100644
--- a/meta/recipes-devtools/expect/expect_5.45.4.bb
+++ b/meta/recipes-devtools/expect/expect_5.45.4.bb
@@ -44,9 +44,9 @@ do_install_append() {
}
# Apparently the public Tcl headers are only in /usr/include/tcl8.6
-# when building for the target.
-TCL_INCLUDE_PATH = ""
-TCL_INCLUDE_PATH_class-target = "--with-tclinclude=${STAGING_INCDIR}/tcl8.6"
+# when building for the target and nativesdk.
+TCL_INCLUDE_PATH = "--with-tclinclude=${STAGING_INCDIR}/tcl8.6"
+TCL_INCLUDE_PATH_class-native = ""
EXTRA_OECONF += "--with-tcl=${STAGING_LIBDIR} \
--enable-shared \