summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre-Jean Texier <pjtexier@koncepto.io>2020-05-01 14:19:28 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-05-03 15:38:03 +0100
commitaaf4054cb9e2c73d34e6fab12bf140808b2612ac (patch)
tree2f7dfc02a2de798dc86727d69bc5b58d2959514b
parentbbb2d451d6290d8ec312890fd5d3bc5c6d0e7468 (diff)
downloadopenembedded-core-contrib-aaf4054cb9e2c73d34e6fab12bf140808b2612ac.tar.gz
curl: support mqtt in PACKAGECONFIG
The version 7.70.0 of curl add experimental support for this protocol. So, add PACKAGECONFIG for mqtt. See [1] for more informations. [1] - https://github.com/curl/curl/blob/master/docs/MQTT.md Signed-off-by: Pierre-Jean Texier <pjtexier@koncepto.io> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/curl/curl_7.70.0.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-support/curl/curl_7.70.0.bb b/meta/recipes-support/curl/curl_7.70.0.bb
index d3d8d2caca..baf72f8e75 100644
--- a/meta/recipes-support/curl/curl_7.70.0.bb
+++ b/meta/recipes-support/curl/curl_7.70.0.bb
@@ -34,6 +34,7 @@ PACKAGECONFIG[ldaps] = "--enable-ldaps,--disable-ldaps,"
PACKAGECONFIG[libidn] = "--with-libidn2,--without-libidn2,libidn2"
PACKAGECONFIG[libssh2] = "--with-libssh2,--without-libssh2,libssh2"
PACKAGECONFIG[mbedtls] = "--with-mbedtls=${STAGING_DIR_TARGET},--without-mbedtls,mbedtls"
+PACKAGECONFIG[mqtt] = "--enable-mqtt,--disable-mqtt,"
PACKAGECONFIG[nghttp2] = "--with-nghttp2,--without-nghttp2,nghttp2"
PACKAGECONFIG[pop3] = "--enable-pop3,--disable-pop3,"
PACKAGECONFIG[proxy] = "--enable-proxy,--disable-proxy,"