summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Burdukiewicz <bartlomiej.burdukiewicz@gmail.com>2020-04-29 22:27:44 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-05-02 09:08:46 +0100
commit65b7b48cd6c7ec88da4dc8bcc3e93fe2703a8fef (patch)
tree066489ca77c8a8e92763e573ccf3785d3613a2fa
parent1d5df7310ee119b71494f97ae86f0fa264ae3022 (diff)
downloadopenembedded-core-contrib-65b7b48cd6c7ec88da4dc8bcc3e93fe2703a8fef.tar.gz
libva: add PACKAGECONFIG and additonal rules for glx.
* glx PACKAGECONFIG by default is selected when x11 and opengl flag is present in DISTRO_FEATURES. * virtual/mesa is only required when glx driver is selected to build. Signed-off-by: Bartłomiej Burdukiewicz <bartlomiej.burdukiewicz@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/libva/libva_2.6.1.bb14
1 files changed, 10 insertions, 4 deletions
diff --git a/meta/recipes-graphics/libva/libva_2.6.1.bb b/meta/recipes-graphics/libva/libva_2.6.1.bb
index 92cea83bc1..8c495bad70 100644
--- a/meta/recipes-graphics/libva/libva_2.6.1.bb
+++ b/meta/recipes-graphics/libva/libva_2.6.1.bb
@@ -23,15 +23,21 @@ SRC_URI[sha256sum] = "6c57eb642d828af2411aa38f55dc10111e8c98976dbab8fd62e4862940
UPSTREAM_CHECK_URI = "https://github.com/intel/libva/releases"
-DEPENDS = "libdrm virtual/mesa"
+DEPENDS = "libdrm"
inherit meson pkgconfig features_check
REQUIRED_DISTRO_FEATURES = "opengl"
-PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
-PACKAGECONFIG[x11] = "-Dwith_x11=yes, -Dwith_x11=no,virtual/libx11 libxext libxfixes"
-PACKAGECONFIG[wayland] = "-Dwith_wayland=yes, -Dwith_wayland=no,wayland-native wayland"
+PACKAGECONFIG ??= " \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'glx', '', d)} \
+ ${@bb.utils.filter('DISTRO_FEATURES', 'x11 wayland', d)} \
+"
+
+PACKAGECONFIG[x11] = "-Dwith_x11=yes,-Dwith_x11=no,virtual/libx11 libxext libxfixes"
+PACKAGECONFIG[glx] = "-Dwith_glx=yes,-Dwith_glx=no,virtual/mesa"
+
+PACKAGECONFIG[wayland] = "-Dwith_wayland=yes,-Dwith_wayland=no,wayland-native wayland"
PACKAGES =+ "${PN}-x11 ${PN}-glx ${PN}-wayland"