summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-05-03 18:25:58 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-05-05 13:18:41 +0100
commit430fccaf952e4e327d8f8898e83a1db3019ffd47 (patch)
tree03c110bdbb1eeb91b0892b2c50a4220ef47fb077
parentce2948af5293258a69a9cfefba9e883cefecac87 (diff)
downloadopenembedded-core-contrib-430fccaf952e4e327d8f8898e83a1db3019ffd47.tar.gz
xkeyboard-config: update to 2.29
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/xorg-lib/xkeyboard-config/0001-fix-python3-support.patch34
-rw-r--r--meta/recipes-graphics/xorg-lib/xkeyboard-config_2.29.bb (renamed from meta/recipes-graphics/xorg-lib/xkeyboard-config_2.28.bb)8
2 files changed, 39 insertions, 3 deletions
diff --git a/meta/recipes-graphics/xorg-lib/xkeyboard-config/0001-fix-python3-support.patch b/meta/recipes-graphics/xorg-lib/xkeyboard-config/0001-fix-python3-support.patch
new file mode 100644
index 0000000000..f723f70332
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/xkeyboard-config/0001-fix-python3-support.patch
@@ -0,0 +1,34 @@
+From 168ac446cdd9a1b59d6b708360a9556515ba56b9 Mon Sep 17 00:00:00 2001
+From: MilhouseVH <milhouseVH.github@nmacleod.com>
+Date: Sun, 16 Feb 2020 09:41:43 +0000
+Subject: [PATCH] fix python3 support
+
+https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config/issues/197
+
+Upstream-Status: Backport
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ rules/compat/map-variants.py | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/rules/compat/map-variants.py b/rules/compat/map-variants.py
+index ebbfec9..979ba43 100755
+--- a/rules/compat/map-variants.py
++++ b/rules/compat/map-variants.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python3
++#!/usr/bin/env python3
+
+ import argparse
+ import re
+@@ -12,8 +12,8 @@ class Layout(object):
+ assert variant is None
+ # parse a layout(variant) string
+ match = re.match(r'([^(]+)\(([^)]+)\)', layout)
+- self.layout = match[1]
+- self.variant = match[2]
++ self.layout = match.groups()[0]
++ self.variant = match.groups()[1]
+
+ def __str__(self):
+ if self.variant:
diff --git a/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.28.bb b/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.29.bb
index 7a3d694bd6..598b584787 100644
--- a/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.28.bb
+++ b/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.29.bb
@@ -12,9 +12,11 @@ BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=xkeyboard-confi
LICENSE = "MIT & MIT-style"
LIC_FILES_CHKSUM = "file://COPYING;md5=0e7f21ca7db975c63467d2e7624a12f9"
-SRC_URI = "${XORG_MIRROR}/individual/data/xkeyboard-config/${BPN}-${PV}.tar.bz2"
-SRC_URI[md5sum] = "5a968ab77846ff85a04242410b2a61de"
-SRC_URI[sha256sum] = "69adb25b0fc64e4075f8ec0eab8d869892419f474f91fb69db1713de2062bdce"
+SRC_URI = "${XORG_MIRROR}/individual/data/xkeyboard-config/${BPN}-${PV}.tar.bz2 \
+ file://0001-fix-python3-support.patch \
+ "
+SRC_URI[md5sum] = "b5980bdc6c7d79f6dcccba8c76bb6c5d"
+SRC_URI[sha256sum] = "1d4175278bf06000683656763a8b1d3282c61a314b6db41260c8efe92d621802"
SECTION = "x11/libs"
DEPENDS = "util-macros libxslt-native"