summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2019-09-17 21:11:10 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-09-19 15:26:47 +0100
commit101d1ea3fe2d40ddde3139952545fa7128478f66 (patch)
tree0cb9386fe32d3a26481c2051ad9dee77c7730c23
parentd046afd12e1c209b29dca6ba402b9aa14680c5ce (diff)
downloadopenembedded-core-contrib-101d1ea3fe2d40ddde3139952545fa7128478f66.tar.gz
systemd: Handle slow to boot mips hwdb update timeouts
This is a temporary workaround to avoid autobuilder failures until https://github.com/systemd/systemd/issues/13581 is resolved. Its being done globally even though its a mips problem for simplicity, it doesn't hurt anything else to have a longer timeout. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/systemd/systemd_243.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd_243.bb b/meta/recipes-core/systemd/systemd_243.bb
index 3ae1516dfb..f0e8c569b8 100644
--- a/meta/recipes-core/systemd/systemd_243.bb
+++ b/meta/recipes-core/systemd/systemd_243.bb
@@ -298,6 +298,11 @@ do_install() {
install -Dm 0644 ${WORKDIR}/99-default.preset ${D}${systemd_unitdir}/system-preset/99-default.preset
}
+do_install_append () {
+ # Mips qemu is extremely slow, allow more time for the hwdb update
+ # This is a workaround until https://github.com/systemd/systemd/issues/13581 is resolved
+ sed -i -e s#TimeoutSec=90s#TimeoutSec=180s# ${D}${systemd_unitdir}/system/systemd-hwdb-update.service
+}
python populate_packages_prepend (){
systemdlibdir = d.getVar("rootlibdir")