aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2015-06-09 15:20:10 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-11 23:55:45 +0100
commite1570e12f92bf359ef34d0e2998b09981bcece18 (patch)
tree83fce775b0e2e29b2882fe8eb7c072ffd1685d4f
parent659d0300187accaff393d2b988aef6b58972ed8d (diff)
downloadopenembedded-core-contrib-e1570e12f92bf359ef34d0e2998b09981bcece18.tar.gz
xorg: fix VESA int10 error
When falling back to the VESA server, X fails to start due to an error reading the int10 vec. We cherry-pick the following commit to fix the error: commit 0a78b599b34cc8b5fe6fe82f90e90234e8ab7a56 Author: Jürg Billeter <j@bitron.ch> Date: Sat Feb 7 18:13:21 2015 +0100 int10: Fix error check for pci_device_map_legacy pci_device_map_legacy returns 0 on success. Signed-off-by: Jürg Billeter <j@bitron.ch> Reviewed-by: Adam Jackson <ajax@redhat.com> Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-graphics/xorg-xserver/xserver-xorg/0001-int10-Fix-error-check-for-pci_device_map_legacy.patch50
-rw-r--r--meta/recipes-graphics/xorg-xserver/xserver-xorg_1.17.1.bb1
2 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-xserver/xserver-xorg/0001-int10-Fix-error-check-for-pci_device_map_legacy.patch b/meta/recipes-graphics/xorg-xserver/xserver-xorg/0001-int10-Fix-error-check-for-pci_device_map_legacy.patch
new file mode 100644
index 0000000000..28b3218a30
--- /dev/null
+++ b/meta/recipes-graphics/xorg-xserver/xserver-xorg/0001-int10-Fix-error-check-for-pci_device_map_legacy.patch
@@ -0,0 +1,50 @@
+From 0a78b599b34cc8b5fe6fe82f90e90234e8ab7a56 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?J=C3=BCrg=20Billeter?= <j@bitron.ch>
+Date: Sat, 7 Feb 2015 18:13:21 +0100
+Subject: [PATCH] int10: Fix error check for pci_device_map_legacy
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+pci_device_map_legacy returns 0 on success.
+
+Upstream-status: backport 0a78b599b34cc8b5fe6fe82f90e90234e8ab7a56
+
+Signed-off-by: Jürg Billeter <j@bitron.ch>
+Reviewed-by: Adam Jackson <ajax@redhat.com>
+Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
+Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
+---
+ hw/xfree86/int10/generic.c | 2 +-
+ hw/xfree86/os-support/linux/int10/linux.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/hw/xfree86/int10/generic.c b/hw/xfree86/int10/generic.c
+index 012d194..8d5c4da 100644
+--- a/hw/xfree86/int10/generic.c
++++ b/hw/xfree86/int10/generic.c
+@@ -104,7 +104,7 @@ readIntVec(struct pci_device *dev, unsigned char *buf, int len)
+ {
+ void *map;
+
+- if (!pci_device_map_legacy(dev, 0, len, 0, &map))
++ if (pci_device_map_legacy(dev, 0, len, 0, &map))
+ return FALSE;
+
+ memcpy(buf, map, len);
+diff --git a/hw/xfree86/os-support/linux/int10/linux.c b/hw/xfree86/os-support/linux/int10/linux.c
+index 79b9a88..6ca118f 100644
+--- a/hw/xfree86/os-support/linux/int10/linux.c
++++ b/hw/xfree86/os-support/linux/int10/linux.c
+@@ -75,7 +75,7 @@ readLegacy(struct pci_device *dev, unsigned char *buf, int base, int len)
+ {
+ void *map;
+
+- if (!pci_device_map_legacy(dev, base, len, 0, &map))
++ if (pci_device_map_legacy(dev, base, len, 0, &map))
+ return FALSE;
+
+ memcpy(buf, map, len);
+--
+2.1.4
+
diff --git a/meta/recipes-graphics/xorg-xserver/xserver-xorg_1.17.1.bb b/meta/recipes-graphics/xorg-xserver/xserver-xorg_1.17.1.bb
index 82051b36aa..edca51e568 100644
--- a/meta/recipes-graphics/xorg-xserver/xserver-xorg_1.17.1.bb
+++ b/meta/recipes-graphics/xorg-xserver/xserver-xorg_1.17.1.bb
@@ -6,6 +6,7 @@ SRC_URI += "file://fix_open_max_preprocessor_error.patch \
file://xtrans.patch \
file://0001-use-__GLIBC__-guard-for-glibc-specific-code.patch \
file://0001-sdksyms.sh-Make-sdksyms.sh-work-with-gcc5.patch \
+ file://0001-int10-Fix-error-check-for-pci_device_map_legacy.patch \
"
SRC_URI[md5sum] = "5986510d59e394a50126a8e2833e79d3"