aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2015-06-09 19:37:49 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-11 23:55:45 +0100
commit9c25af5483280c5c753f981504eb373d6e58c7f3 (patch)
treebe59bda73b5c5e7e02191fa92679eff8f76029b5
parent2c8d6320ca4db7f7158a3e69467bee5c8ca8fed5 (diff)
downloadopenembedded-core-contrib-9c25af5483280c5c753f981504eb373d6e58c7f3.tar.gz
cups: clean up autotools use
Instead of hand-rolling a do_configure() simply use autotools and disable autoheader (upstream uses a hand-generated config.h.in). Also do_compile() doesn't need to pass SSLLIBS as configure uses pkgconfig to find gnutls, LIBPNG and LIBJPEG are not used anywhere in the build system, and LIBZ is detected correctly. Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-extended/cups/cups.inc14
1 files changed, 2 insertions, 12 deletions
diff --git a/meta/recipes-extended/cups/cups.inc b/meta/recipes-extended/cups/cups.inc
index df47c81d59..ba50296ba7 100644
--- a/meta/recipes-extended/cups/cups.inc
+++ b/meta/recipes-extended/cups/cups.inc
@@ -43,13 +43,7 @@ EXTRA_OECONF = " \
--without-java \
"
-
-do_configure() {
- gnu-configize
- libtoolize --force
- autoconf --force
- DSOFLAGS="${LDFLAGS}" SERVERBIN="${libdir}/cups" oe_runconf
-}
+EXTRA_AUTORECONF += "--exclude=autoheader"
do_compile () {
sed -i s:STRIP:NOSTRIP: Makedefs
@@ -63,11 +57,7 @@ do_compile () {
echo "install-headers:" >> man/Makefile
echo "install-libs:" >> man/Makefile
- oe_runmake "SSLLIBS=-lgnutls -L${STAGING_LIBDIR}" \
- "LIBPNG=-lpng -lm -L${STAGING_LIBDIR}" \
- "LIBJPEG=-ljpeg -L${STAGING_LIBDIR}" \
- "LIBZ=-lz -L${STAGING_LIBDIR}" \
- "-I."
+ oe_runmake
}
do_install () {