aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2017-08-16 04:31:19 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-17 14:04:16 +0100
commitb90037da8754009ca7cf2ab996b46b3dae1eb204 (patch)
tree6a6609f0758453ca4bd3740c5fa4a66fced8b334
parent4ca17f9275c81f27498b7ac07d9fe7e8193fdd71 (diff)
downloadopenembedded-core-contrib-b90037da8754009ca7cf2ab996b46b3dae1eb204.tar.gz
libgcrypt: 1.7.8 -> 1.8.0
Rebase patches: - add-pkgconfig-support.patch -> 0001 - libgcrypt-fix-building-error-with-O2-in-sysroot-path.patch -> 0002 - fix-ICE-failure-on-mips-with-option-O-and-g.patch -> 0003 - fix-undefined-reference-to-pthread.patch -> 0004 Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/libgcrypt/files/0001-Add-and-use-pkg-config-for-libgcrypt-instead-of-conf.patch (renamed from meta/recipes-support/libgcrypt/files/add-pkgconfig-support.patch)18
-rw-r--r--meta/recipes-support/libgcrypt/files/0002-libgcrypt-fix-building-error-with-O2-in-sysroot-path.patch (renamed from meta/recipes-support/libgcrypt/files/libgcrypt-fix-building-error-with-O2-in-sysroot-path.patch)29
-rw-r--r--meta/recipes-support/libgcrypt/files/0003-tests-bench-slope.c-workaround-ICE-failure-on-mips-w.patch (renamed from meta/recipes-support/libgcrypt/files/fix-ICE-failure-on-mips-with-option-O-and-g.patch)24
-rw-r--r--meta/recipes-support/libgcrypt/files/0004-tests-Makefile.am-fix-undefined-reference-to-pthread.patch (renamed from meta/recipes-support/libgcrypt/files/fix-undefined-reference-to-pthread.patch)11
-rw-r--r--meta/recipes-support/libgcrypt/libgcrypt_1.8.0.bb (renamed from meta/recipes-support/libgcrypt/libgcrypt_1.7.8.bb)12
5 files changed, 59 insertions, 35 deletions
diff --git a/meta/recipes-support/libgcrypt/files/add-pkgconfig-support.patch b/meta/recipes-support/libgcrypt/files/0001-Add-and-use-pkg-config-for-libgcrypt-instead-of-conf.patch
index 69589f5482..d41c3de3b6 100644
--- a/meta/recipes-support/libgcrypt/files/add-pkgconfig-support.patch
+++ b/meta/recipes-support/libgcrypt/files/0001-Add-and-use-pkg-config-for-libgcrypt-instead-of-conf.patch
@@ -1,10 +1,16 @@
-Add and use pkg-config for libgcrypt instead of -config scripts.
+From 72b9e9040d58c15f0302bd8abda28179f04e1c5f Mon Sep 17 00:00:00 2001
+From: Richard Purdie <richard.purdie@linuxfoundation.org>
+Date: Wed, 16 Aug 2017 10:43:18 +0800
+Subject: [PATCH 1/4] Add and use pkg-config for libgcrypt instead of -config
+ scripts.
-Upstream-Status: Denied [upstream have indicated they don't want a pkg-config dependency]
+Upstream-Status: Denied [upstream have indicated they don't want a
+pkg-config dependency]
RP 2014/5/22
-Rebase to 1.7.0
+Rebase to 1.8.0
+
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
---
configure.ac | 1 +
@@ -14,10 +20,10 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
create mode 100644 src/libgcrypt.pc.in
diff --git a/configure.ac b/configure.ac
-index f683e21..566e1c8 100644
+index bbe8104..3d2de73 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -2314,6 +2314,7 @@ random/Makefile
+@@ -2607,6 +2607,7 @@ random/Makefile
doc/Makefile
src/Makefile
src/gcrypt.h
@@ -173,5 +179,5 @@ index 0000000..2fc8f53
+Libs.private: -L${libdir} -lgpg-error
+Cflags: -I${includedir}
--
-2.8.1
+1.8.3.1
diff --git a/meta/recipes-support/libgcrypt/files/libgcrypt-fix-building-error-with-O2-in-sysroot-path.patch b/meta/recipes-support/libgcrypt/files/0002-libgcrypt-fix-building-error-with-O2-in-sysroot-path.patch
index a3e540369c..d7554f38af 100644
--- a/meta/recipes-support/libgcrypt/files/libgcrypt-fix-building-error-with-O2-in-sysroot-path.patch
+++ b/meta/recipes-support/libgcrypt/files/0002-libgcrypt-fix-building-error-with-O2-in-sysroot-path.patch
@@ -1,25 +1,34 @@
-Upstream-Status: Pending
+From 97570ef271ea1fb7b5ca903eec88f68407b0ec76 Mon Sep 17 00:00:00 2001
+From: Chen Qi <Qi.Chen@windriver.com>
+Date: Wed, 16 Aug 2017 10:44:41 +0800
+Subject: [PATCH 2/4] libgcrypt: fix building error with '-O2' in sysroot path
-libgcrypt: fix building error with '-O2' in sysroot path
+Upstream-Status: Pending
-Characters like '-O2' or '-Ofast' will be replaced by '-O1' when compiling cipher.
-If we are cross compiling libgcrypt and sysroot contains such characters, we would
+Characters like '-O2' or '-Ofast' will be replaced by '-O1' when
+compiling cipher.
+If we are cross compiling libgcrypt and sysroot contains such
+characters, we would
get compile errors because the sysroot path has been modified.
-Fix this by adding blank spaces before and after the original matching pattern in the
+Fix this by adding blank spaces before and after the original matching
+pattern in the
sed command.
Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
+
+Rebase to 1.8.0
+Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
---
- cipher/Makefile.am | 2 +-
+ cipher/Makefile.am | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/cipher/Makefile.am b/cipher/Makefile.am
-index 76cdc96..9a89792 100644
+index 95c4510..bd52ec7 100644
--- a/cipher/Makefile.am
+++ b/cipher/Makefile.am
-@@ -69,7 +69,7 @@ rfc2268.c \
- camellia.c camellia.h camellia-glue.c
+@@ -116,7 +116,7 @@ gost-s-box: gost-s-box.c
+
if ENABLE_O_FLAG_MUNGING
-o_flag_munging = sed -e 's/-O\([2-9s][2-9s]*\)/-O1/' -e 's/-Ofast/-O1/g'
@@ -28,5 +37,5 @@ index 76cdc96..9a89792 100644
o_flag_munging = cat
endif
--
-1.7.9.5
+1.8.3.1
diff --git a/meta/recipes-support/libgcrypt/files/fix-ICE-failure-on-mips-with-option-O-and-g.patch b/meta/recipes-support/libgcrypt/files/0003-tests-bench-slope.c-workaround-ICE-failure-on-mips-w.patch
index 582e62f709..105df2957e 100644
--- a/meta/recipes-support/libgcrypt/files/fix-ICE-failure-on-mips-with-option-O-and-g.patch
+++ b/meta/recipes-support/libgcrypt/files/0003-tests-bench-slope.c-workaround-ICE-failure-on-mips-w.patch
@@ -1,4 +1,8 @@
-tests/bench-slope.c: workaround ICE failure on mips with '-O -g'
+From 7cc702c7b5a1ccc2b0091f3effa1391b6c3030fd Mon Sep 17 00:00:00 2001
+From: Hongxu Jia <hongxu.jia@windriver.com>
+Date: Wed, 16 Aug 2017 10:46:28 +0800
+Subject: [PATCH 3/4] tests/bench-slope.c: workaround ICE failure on mips with
+ '-O -g'
Hit a ICE and could reduce it to the following minimal example:
@@ -24,31 +28,35 @@ END
2. Only -O1 and -g on mips caused the issue:
$ mips-poky-linux-gcc -O1 -g -o mipgcc-test mipgcc-test.c
mipgcc-test.c: In function 'main':
-mipgcc-test.c:18:1: internal compiler error: in dwarf2out_var_location, at dwarf2out.c:20810
+mipgcc-test.c:18:1: internal compiler error: in dwarf2out_var_location,
+at dwarf2out.c:20810
}
^
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://gcc.gnu.org/bugs.html> for instructions
-3. The quick workround is trying to enlarge the size of array with larger
+3. The quick workround is trying to enlarge the size of array with
+larger
than 2.
-4. File a bug to GNU, but it could not be reproduced on there environment.
+4. File a bug to GNU, but it could not be reproduced on there
+environment.
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=60643
Upstream-Status: Inappropriate [oe specific]
+Rebase to 1.8.0
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
---
tests/bench-slope.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/tests/bench-slope.c b/tests/bench-slope.c
-index bd05064..28c2438 100644
+index 75e6e43..4e70842 100644
--- a/tests/bench-slope.c
+++ b/tests/bench-slope.c
-@@ -1197,7 +1197,7 @@ static struct bench_ops hash_ops = {
+@@ -1463,7 +1463,7 @@ static struct bench_ops hash_ops = {
};
@@ -57,7 +65,7 @@ index bd05064..28c2438 100644
{"", &hash_ops},
{0},
};
-@@ -1349,7 +1349,7 @@ static struct bench_ops mac_ops = {
+@@ -1629,7 +1629,7 @@ static struct bench_ops mac_ops = {
};
@@ -67,5 +75,5 @@ index bd05064..28c2438 100644
{0},
};
--
-1.8.1.2
+1.8.3.1
diff --git a/meta/recipes-support/libgcrypt/files/fix-undefined-reference-to-pthread.patch b/meta/recipes-support/libgcrypt/files/0004-tests-Makefile.am-fix-undefined-reference-to-pthread.patch
index e7de8badf8..8622df3ea8 100644
--- a/meta/recipes-support/libgcrypt/files/fix-undefined-reference-to-pthread.patch
+++ b/meta/recipes-support/libgcrypt/files/0004-tests-Makefile.am-fix-undefined-reference-to-pthread.patch
@@ -1,7 +1,8 @@
-From cc0e2b403d33892963513a3ba98e4ae5a05a4d3c Mon Sep 17 00:00:00 2001
+From e20dbdb0b8f0af840ef90b299c4e2277c52ddf87 Mon Sep 17 00:00:00 2001
From: Hongxu Jia <hongxu.jia@windriver.com>
Date: Sun, 12 Jun 2016 04:44:29 -0400
-Subject: [PATCH] tests/Makefile.am: fix undefined reference to `pthread_create'
+Subject: [PATCH 4/4] tests/Makefile.am: fix undefined reference to
+ `pthread_create'
Add missing '-lpthread' to CFLAGS
@@ -13,15 +14,15 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tests/Makefile.am b/tests/Makefile.am
-index d462f30..bef6dd7 100644
+index 1744ea7..04cf425 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
-@@ -62,4 +62,4 @@ EXTRA_DIST = README rsa-16k.key cavs_tests.sh cavs_driver.pl \
+@@ -64,4 +64,4 @@ EXTRA_DIST = README rsa-16k.key cavs_tests.sh cavs_driver.pl \
LDADD = $(standard_ldadd) $(GPG_ERROR_LIBS)
t_lock_LDADD = $(standard_ldadd) $(GPG_ERROR_MT_LIBS)
-t_lock_CFLAGS = $(GPG_ERROR_MT_CFLAGS)
+t_lock_CFLAGS = $(GPG_ERROR_MT_CFLAGS) -lpthread
--
-2.8.1
+1.8.3.1
diff --git a/meta/recipes-support/libgcrypt/libgcrypt_1.7.8.bb b/meta/recipes-support/libgcrypt/libgcrypt_1.8.0.bb
index ec8b875efa..1797d9584d 100644
--- a/meta/recipes-support/libgcrypt/libgcrypt_1.7.8.bb
+++ b/meta/recipes-support/libgcrypt/libgcrypt_1.8.0.bb
@@ -16,13 +16,13 @@ DEPENDS = "libgpg-error"
UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
SRC_URI = "${GNUPG_MIRROR}/libgcrypt/libgcrypt-${PV}.tar.gz \
- file://add-pkgconfig-support.patch \
- file://libgcrypt-fix-building-error-with-O2-in-sysroot-path.patch \
- file://fix-ICE-failure-on-mips-with-option-O-and-g.patch \
- file://fix-undefined-reference-to-pthread.patch \
+ file://0001-Add-and-use-pkg-config-for-libgcrypt-instead-of-conf.patch \
+ file://0003-tests-bench-slope.c-workaround-ICE-failure-on-mips-w.patch \
+ file://0002-libgcrypt-fix-building-error-with-O2-in-sysroot-path.patch \
+ file://0004-tests-Makefile.am-fix-undefined-reference-to-pthread.patch \
"
-SRC_URI[md5sum] = "5588b89b75b1353e2454b04c7b8368f3"
-SRC_URI[sha256sum] = "cb076b2efc7ba752f3d4c663c9ee0589a98b1d614fe90878b1facd607a45fd43"
+SRC_URI[md5sum] = "110ce4352f9ea6f560bdc6c5644ae93c"
+SRC_URI[sha256sum] = "f6e470b7f2d3a703e8747f05a8c19d9e10e26ebf2d5f3d71ff75a40f504e12ee"
BINCONFIG = "${bindir}/libgcrypt-config"