aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2017-02-12 22:54:58 -0800
committerRobert Yang <liezhi.yang@windriver.com>2017-02-20 02:21:12 +0000
commit9c6af066d46ac01df8954b4a8c8ad8f7ee469e84 (patch)
tree7c29acd981fe138d055592c92a1fabd806ba9e18
parent0a3a087f8c908c934562f4ca8cc907db53edf128 (diff)
downloadopenembedded-core-contrib-9c6af066d46ac01df8954b4a8c8ad8f7ee469e84.tar.gz
tcl: fix sed in do_install()
The command: sed -i "s+${WORKDIR}+${STAGING_INCDIR}+g" tclConfig.sh was used for replacing "${WORKDIR}", but it also replaced "-L${WORKDIR}", but binconfig.bbclass would replace "-L${WORKDIR}", too, which caused incorrect result, use "'${WORKDIR}" to fix the problem. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta/recipes-devtools/tcltk/tcl_8.6.6.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/tcltk/tcl_8.6.6.bb b/meta/recipes-devtools/tcltk/tcl_8.6.6.bb
index c828b38772..40cd18fb09 100644
--- a/meta/recipes-devtools/tcltk/tcl_8.6.6.bb
+++ b/meta/recipes-devtools/tcltk/tcl_8.6.6.bb
@@ -55,7 +55,7 @@ do_install() {
ln -sf ./tclsh${VER} ${D}${bindir}/tclsh
ln -sf tclsh8.6 ${D}${bindir}/tclsh${VER}
sed -i "s;-L${B};-L${STAGING_LIBDIR};g" tclConfig.sh
- sed -i "s;${WORKDIR};${STAGING_INCDIR};g" tclConfig.sh
+ sed -i "s;'${WORKDIR};'${STAGING_INCDIR};g" tclConfig.sh
install -d ${D}${bindir_crossscripts}
install -m 0755 tclConfig.sh ${D}${bindir_crossscripts}
install -m 0755 tclConfig.sh ${D}${libdir}