summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2019-06-14 11:28:07 +0800
committerRobert Yang <liezhi.yang@windriver.com>2019-06-20 15:54:24 +0800
commitb0d4e2fd7162cf0b181d3a969418757a4e62fd72 (patch)
tree69800fd974df46f5a0111d4aeb22ddf0531fefc4
parent2106a567820bad438ff78d54a49e3d87da428dcf (diff)
downloadopenembedded-core-contrib-b0d4e2fd7162cf0b181d3a969418757a4e62fd72.tar.gz
linux-dummy: Add do_compile_kernelmodules
Fixed: PREFERRED_PROVIDER_virtual/kernel = "linux-dummy" $ bitbake world ERROR: Task do_compile in make-mod-scripts_1.0.bb depends upon non-existent task do_compile_kernelmodules in linux-dummy.bb ERROR: Command execution failed: Exited with 1 Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta/recipes-kernel/linux/linux-dummy.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-dummy.bb b/meta/recipes-kernel/linux/linux-dummy.bb
index e1c7f76760..62cf6f5ea6 100644
--- a/meta/recipes-kernel/linux/linux-dummy.bb
+++ b/meta/recipes-kernel/linux/linux-dummy.bb
@@ -39,6 +39,10 @@ do_compile () {
:
}
+do_compile_kernelmodules() {
+ :
+}
+
do_shared_workdir () {
:
}
@@ -58,3 +62,4 @@ do_deploy() {
addtask bundle_initramfs after do_install before do_deploy
addtask deploy after do_install
addtask shared_workdir after do_compile before do_install
+addtask compile_kernelmodules