summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-11-28 23:47:59 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-11-30 14:40:55 +0000
commit13ff38ffd216fcd7044d7a0f46c8907d64ce3f6e (patch)
tree0da7ca3e696b3982a9a9b383dd20a0d0579360c6
parent968994491db660515f7bd8f1a0dc64c8e22c5dfa (diff)
downloadopenembedded-core-contrib-13ff38ffd216fcd7044d7a0f46c8907d64ce3f6e.tar.gz
python3-numpy: Add ptest
Since 1.15, numpy have replaced nose with pytest testing framework it additionally needs hypothesis and sortedcontainers modules Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python-numpy/files/run-ptest5
-rw-r--r--meta/recipes-devtools/python-numpy/python3-numpy_1.19.4.bb10
2 files changed, 13 insertions, 2 deletions
diff --git a/meta/recipes-devtools/python-numpy/files/run-ptest b/meta/recipes-devtools/python-numpy/files/run-ptest
new file mode 100644
index 0000000000..9a1c72aeb1
--- /dev/null
+++ b/meta/recipes-devtools/python-numpy/files/run-ptest
@@ -0,0 +1,5 @@
+#!/usr/bin/env python3
+
+import numpy
+numpy.test(label='full', verbose=2)
+
diff --git a/meta/recipes-devtools/python-numpy/python3-numpy_1.19.4.bb b/meta/recipes-devtools/python-numpy/python3-numpy_1.19.4.bb
index d54f2f6c18..2bfc913aa0 100644
--- a/meta/recipes-devtools/python-numpy/python3-numpy_1.19.4.bb
+++ b/meta/recipes-devtools/python-numpy/python3-numpy_1.19.4.bb
@@ -8,6 +8,7 @@ SRCNAME = "numpy"
SRC_URI = "https://github.com/${SRCNAME}/${SRCNAME}/releases/download/v${PV}/${SRCNAME}-${PV}.tar.gz \
file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \
file://0001-numpy-core-Define-RISCV-32-support.patch \
+ file://run-ptest \
"
SRC_URI[sha256sum] = "fe836a685d6838dbb3f603caef01183ea98e88febf4ce956a2ea484a75378413"
@@ -16,7 +17,7 @@ UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
DEPENDS += "python3-cython-native"
-inherit setuptools3
+inherit ptest setuptools3
S = "${WORKDIR}/numpy-${PV}"
@@ -30,7 +31,6 @@ RDEPENDS_${PN} = "${PYTHON_PN}-unittest \
${PYTHON_PN}-pprint \
${PYTHON_PN}-pickle \
${PYTHON_PN}-shell \
- ${PYTHON_PN}-nose \
${PYTHON_PN}-doctest \
${PYTHON_PN}-datetime \
${PYTHON_PN}-distutils \
@@ -46,6 +46,12 @@ RDEPENDS_${PN} = "${PYTHON_PN}-unittest \
${PYTHON_PN}-threading \
${PYTHON_PN}-multiprocessing \
"
+RDEPENDS_${PN}-ptest += "${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-hypothesis \
+ ${PYTHON_PN}-sortedcontainers \
+ ${PYTHON_PN}-resource \
+ ldd \
+"
RDEPENDS_${PN}_class-native = ""