summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2022-03-11 12:02:04 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-12 09:20:00 +0000
commit15baf24f750ab2c8b0a46d4a3bf2ae9bfa3d0aff (patch)
tree8069a5bcf546b0b5c3bc0ae3680bc3c8ebb49f0d
parentc4ecd63593df2ffd5c1b7ae1c50652ca57ebe219 (diff)
downloadopenembedded-core-contrib-15baf24f750ab2c8b0a46d4a3bf2ae9bfa3d0aff.tar.gz
meta: remove obsolete PIP_INSTALL_PACKAGE
PIP_INSTALL_PACKAGE isn't used anymore, so remove all instances of it from the recipes. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/meson/meson_0.61.2.bb2
-rw-r--r--meta/recipes-devtools/python/python3-dbusmock_0.26.1.bb1
-rw-r--r--meta/recipes-devtools/python/python3-flit-core_3.7.1.bb1
-rw-r--r--meta/recipes-devtools/python/python3-libarchive-c_4.0.bb2
-rw-r--r--meta/recipes-devtools/python/python3-magic_0.4.25.bb1
-rw-r--r--meta/recipes-devtools/python/python3-more-itertools_8.12.0.bb2
-rw-r--r--meta/recipes-devtools/python/python3-numpy_1.22.2.bb1
-rw-r--r--meta/recipes-devtools/python/python3-strict-rfc3339_0.7.bb2
-rw-r--r--meta/recipes-devtools/python/python3-subunit_1.4.0.bb2
-rw-r--r--meta/recipes-extended/asciidoc/asciidoc_10.1.4.bb1
-rw-r--r--meta/recipes-gnome/gi-docgen/gi-docgen_git.bb1
-rw-r--r--meta/recipes-support/bmap-tools/bmap-tools_git.bb2
12 files changed, 0 insertions, 18 deletions
diff --git a/meta/recipes-devtools/meson/meson_0.61.2.bb b/meta/recipes-devtools/meson/meson_0.61.2.bb
index a51db1e3d4..8304bfdac9 100644
--- a/meta/recipes-devtools/meson/meson_0.61.2.bb
+++ b/meta/recipes-devtools/meson/meson_0.61.2.bb
@@ -23,8 +23,6 @@ UPSTREAM_CHECK_REGEX = "meson-(?P<pver>\d+(\.\d+)+)\.tar"
inherit setuptools_build_meta
-PIP_INSTALL_PACKAGE = "meson"
-
RDEPENDS:${PN} = "ninja python3-modules python3-pkg-resources"
FILES:${PN} += "${datadir}/polkit-1"
diff --git a/meta/recipes-devtools/python/python3-dbusmock_0.26.1.bb b/meta/recipes-devtools/python/python3-dbusmock_0.26.1.bb
index d892ac9804..dc98810726 100644
--- a/meta/recipes-devtools/python/python3-dbusmock_0.26.1.bb
+++ b/meta/recipes-devtools/python/python3-dbusmock_0.26.1.bb
@@ -7,7 +7,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=e6a600fd5e1d9cbde2d983680233ad02"
SRC_URI[sha256sum] = "0e95ef6ec1e6b58aeb0e08839a76972debea94184570f09e29e5f12551399e55"
PYPI_PACKAGE = "python-dbusmock"
-PIP_INSTALL_PACKAGE = "python_dbusmock"
inherit pypi setuptools3
diff --git a/meta/recipes-devtools/python/python3-flit-core_3.7.1.bb b/meta/recipes-devtools/python/python3-flit-core_3.7.1.bb
index c6bc24555e..1f14345d50 100644
--- a/meta/recipes-devtools/python/python3-flit-core_3.7.1.bb
+++ b/meta/recipes-devtools/python/python3-flit-core_3.7.1.bb
@@ -19,7 +19,6 @@ DEPENDS:append:class-native = " unzip-native"
# We need the full flit tarball
PYPI_PACKAGE = "flit"
PEP517_SOURCE_PATH = "${S}/flit_core"
-PIP_INSTALL_PACKAGE = "flit_core"
do_install:class-native () {
pip_install_wheel_do_bootstrap_install
diff --git a/meta/recipes-devtools/python/python3-libarchive-c_4.0.bb b/meta/recipes-devtools/python/python3-libarchive-c_4.0.bb
index 99837848a6..3c6bc1e1ca 100644
--- a/meta/recipes-devtools/python/python3-libarchive-c_4.0.bb
+++ b/meta/recipes-devtools/python/python3-libarchive-c_4.0.bb
@@ -9,8 +9,6 @@ PYPI_PACKAGE = "libarchive-c"
inherit pypi setuptools3
-PIP_INSTALL_PACKAGE = "libarchive_c"
-
SRC_URI[sha256sum] = "a5b41ade94ba58b198d778e68000f6b7de41da768de7140c984f71d7fa8416e5"
RDEPENDS:${PN} += "\
diff --git a/meta/recipes-devtools/python/python3-magic_0.4.25.bb b/meta/recipes-devtools/python/python3-magic_0.4.25.bb
index bd46b294ae..efc8b6daaa 100644
--- a/meta/recipes-devtools/python/python3-magic_0.4.25.bb
+++ b/meta/recipes-devtools/python/python3-magic_0.4.25.bb
@@ -8,7 +8,6 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=61495c152d794e6be5799a9edca149e3"
PYPI_PACKAGE = "python-magic"
-PIP_INSTALL_PACKAGE = "python_magic"
inherit pypi setuptools3
diff --git a/meta/recipes-devtools/python/python3-more-itertools_8.12.0.bb b/meta/recipes-devtools/python/python3-more-itertools_8.12.0.bb
index 5788af3f71..c1e34b205d 100644
--- a/meta/recipes-devtools/python/python3-more-itertools_8.12.0.bb
+++ b/meta/recipes-devtools/python/python3-more-itertools_8.12.0.bb
@@ -7,8 +7,6 @@ SRC_URI[sha256sum] = "7dc6ad46f05f545f900dd59e8dfb4e84a4827b97b3cfecb175ea0c7d24
inherit pypi setuptools3 ptest
-PIP_INSTALL_PACKAGE = "more_itertools"
-
SRC_URI += " \
file://run-ptest \
"
diff --git a/meta/recipes-devtools/python/python3-numpy_1.22.2.bb b/meta/recipes-devtools/python/python3-numpy_1.22.2.bb
index 43e7427eab..6ceb451ff3 100644
--- a/meta/recipes-devtools/python/python3-numpy_1.22.2.bb
+++ b/meta/recipes-devtools/python/python3-numpy_1.22.2.bb
@@ -20,7 +20,6 @@ UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
DEPENDS += "python3-cython-native"
inherit ptest setuptools3
-PIP_INSTALL_PACKAGE = "numpy"
S = "${WORKDIR}/numpy-${PV}"
diff --git a/meta/recipes-devtools/python/python3-strict-rfc3339_0.7.bb b/meta/recipes-devtools/python/python3-strict-rfc3339_0.7.bb
index b592cb95d4..c377c3bfb0 100644
--- a/meta/recipes-devtools/python/python3-strict-rfc3339_0.7.bb
+++ b/meta/recipes-devtools/python/python3-strict-rfc3339_0.7.bb
@@ -8,6 +8,4 @@ SRC_URI[sha256sum] = "5cad17bedfc3af57b399db0fed32771f18fc54bbd917e85546088607ac
inherit pypi setuptools3
-PIP_INSTALL_PACKAGE = "strict_rfc3339"
-
BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-devtools/python/python3-subunit_1.4.0.bb b/meta/recipes-devtools/python/python3-subunit_1.4.0.bb
index bc49a2b69e..e4e3bf191d 100644
--- a/meta/recipes-devtools/python/python3-subunit_1.4.0.bb
+++ b/meta/recipes-devtools/python/python3-subunit_1.4.0.bb
@@ -10,8 +10,6 @@ SRC_URI[sha256sum] = "042039928120fbf392e8c983d60f3d8ae1b88f90a9f8fd7188ddd9c26c
inherit pypi setuptools3
-PIP_INSTALL_PACKAGE = "python_subunit"
-
RDEPENDS:${PN} = " python3-testtools"
BBCLASSEXTEND = "nativesdk"
diff --git a/meta/recipes-extended/asciidoc/asciidoc_10.1.4.bb b/meta/recipes-extended/asciidoc/asciidoc_10.1.4.bb
index 484250b33e..4ab9edbce4 100644
--- a/meta/recipes-extended/asciidoc/asciidoc_10.1.4.bb
+++ b/meta/recipes-extended/asciidoc/asciidoc_10.1.4.bb
@@ -21,7 +21,6 @@ S = "${WORKDIR}/git"
export SGML_CATALOG_FILES="file://${STAGING_ETCDIR_NATIVE}/xml/catalog"
inherit setuptools3
-PIP_INSTALL_PACKAGE = "asciidoc"
CLEANBROKEN = "1"
BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-gnome/gi-docgen/gi-docgen_git.bb b/meta/recipes-gnome/gi-docgen/gi-docgen_git.bb
index 67617fca39..6a7124c3fe 100644
--- a/meta/recipes-gnome/gi-docgen/gi-docgen_git.bb
+++ b/meta/recipes-gnome/gi-docgen/gi-docgen_git.bb
@@ -16,7 +16,6 @@ SRCREV = "37b04455ff58cb2ec3f58917d0737c435344f2fb"
S = "${WORKDIR}/git"
inherit setuptools3
-PIP_INSTALL_PACKAGE = "gi_docgen"
RDEPENDS:${PN} += "python3-asyncio python3-core python3-jinja2 python3-json python3-markdown python3-markupsafe python3-pygments python3-toml python3-typogrify python3-xml"
diff --git a/meta/recipes-support/bmap-tools/bmap-tools_git.bb b/meta/recipes-support/bmap-tools/bmap-tools_git.bb
index 2999fdcea1..78c51e7731 100644
--- a/meta/recipes-support/bmap-tools/bmap-tools_git.bb
+++ b/meta/recipes-support/bmap-tools/bmap-tools_git.bb
@@ -23,6 +23,4 @@ RDEPENDS:${PN} = "python3-core python3-compression python3-mmap python3-setuptoo
inherit setuptools3
-PIP_INSTALL_PACKAGE = "bmap_tools"
-
BBCLASSEXTEND = "native nativesdk"