summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-08-05 23:45:46 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-08-07 16:08:15 +0100
commitbe88cb8424b798cbb03fa03a46db65aeb862f3dd (patch)
treeb9251b25e950edc48e2a2b22360d7720a8664f6a
parent70da7c23b4c6b8ac8ec77cd8afc3143c6956dc9f (diff)
downloadopenembedded-core-contrib-be88cb8424b798cbb03fa03a46db65aeb862f3dd.tar.gz
syslinux: Override hardcoded toolnames in Makefile
makefile assumes native toolnames e.g. ar, as, nm etc. which causes build fails on non-x86 build hosts objcopy: Unable to recognise the format of the input file `libcom32.elf' (From OE-Core rev: ee9afb34fb95409148734fda1eea1fe8f81983fd) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb19
1 files changed, 17 insertions, 2 deletions
diff --git a/meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb b/meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb
index 67e5d57d48..e9dbefb930 100644
--- a/meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb
+++ b/meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb
@@ -59,11 +59,26 @@ do_compile() {
# Rebuild only the installer; keep precompiled bootloaders
# as per author's request (doc/distrib.txt)
- oe_runmake CC="${CC} ${CFLAGS}" LD="${LD}" LDFLAGS="${LDFLAGS}" firmware="bios" installer
+ oe_runmake CC="${CC} ${CFLAGS}" \
+ LD="${LD}" LDFLAGS="${LDFLAGS}" \
+ OBJDUMP="${OBJDUMP}" \
+ OBJCOPY="${OBJCOPY}" \
+ AR="${AR}" \
+ STRIP="${STRIP}" \
+ NM="${NM}" \
+ RANLIB="${RANLIB}" \
+ firmware="bios" installer
}
do_install() {
- oe_runmake CC="${CC} ${CFLAGS}" LD="${LD}" firmware="bios" install INSTALLROOT="${D}"
+ oe_runmake CC="${CC} ${CFLAGS}" LD="${LD}" \
+ OBJDUMP="${OBJDUMP}" \
+ OBJCOPY="${OBJCOPY}" \
+ AR="${AR}" \
+ STRIP="${STRIP}" \
+ NM="${NM}" \
+ RANLIB="${RANLIB}" \
+ firmware="bios" install INSTALLROOT="${D}"
install -d ${D}${datadir}/syslinux/
install -m 644 ${S}/bios/core/ldlinux.sys ${D}${datadir}/syslinux/