aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2007-01-24 14:30:56 +0000
committerRoss Burton <ross@openedhand.com>2007-01-24 14:30:56 +0000
commit192e43f5f84ceb9a54e85bf7adb22d95f57e104c (patch)
treeda1fd334da98ce108b83db779f68cafda7f9bab7
parent0d74b05ad5870ac85e0da4337695cc9dc6b9ce4f (diff)
downloadopenembedded-core-contrib-192e43f5f84ceb9a54e85bf7adb22d95f57e104c.tar.gz
Update for panel 2 and fix packaging bugs
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1201 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rwxr-xr-xmeta/packages/matchbox-sato/matchbox-sato/etc/matchbox/session14
-rw-r--r--meta/packages/matchbox-sato/matchbox-sato_0.1.bb6
2 files changed, 8 insertions, 12 deletions
diff --git a/meta/packages/matchbox-sato/matchbox-sato/etc/matchbox/session b/meta/packages/matchbox-sato/matchbox-sato/etc/matchbox/session
index 46419d8206..e4b4a3b191 100755
--- a/meta/packages/matchbox-sato/matchbox-sato/etc/matchbox/session
+++ b/meta/packages/matchbox-sato/matchbox-sato/etc/matchbox/session
@@ -20,19 +20,15 @@ case `module_id` in
esac
## All this should be done by themeing/xsettings.. ##
-matchbox-desktop --icon-size 48 \
- --icon-padding 64 \
+matchbox-desktop --icon-size 64 \
+ --icon-padding 128 \
--font sans-16:bold \
--titlefont sans-16:bold &
-mb-applet-startup-monitor &
+# mb-applet-startup-monitor &
-#matchbox-panel --orientation east \
-# --padding 4 \
-# --no-menu \
-# --no-session \
-# --default-apps mb-applet-home,mb-applet-clock,mb-applet-battery &
+matchbox-panel --titlebar --start-applets showdesktop --end-applets clock &
-exec matchbox-window-manager -use_cursor $SHOWCURSOR $@
+exec matchbox-window-manager -theme Sato -use_desktop_mode decorated -use_cursor $SHOWCURSOR $@
diff --git a/meta/packages/matchbox-sato/matchbox-sato_0.1.bb b/meta/packages/matchbox-sato/matchbox-sato_0.1.bb
index 49ece1f68c..06721d7e64 100644
--- a/meta/packages/matchbox-sato/matchbox-sato_0.1.bb
+++ b/meta/packages/matchbox-sato/matchbox-sato_0.1.bb
@@ -1,8 +1,8 @@
DESCRIPTION = "Custom MB session files for poky"
LICENSE = "GPL"
SECTION = "x11"
-RDEPENDS = "matchbox matchbox-applet-startup-monitor gtk-sato-engine matchbox-theme-sato"
-PR = "r2"
+RDEPENDS = "matchbox matchbox-applet-startup-monitor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2"
+PR = "r4"
SRC_URI = "file://etc"
S = ${WORKDIR}
@@ -14,7 +14,7 @@ do_install() {
chmod -R 755 ${D}/etc
}
-pkg_postinst_matchbox-poky () {
+pkg_postinst_matchbox-sato () {
#!/bin/sh -e
if [ "x$D" != "x" ]; then
exit 1