aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2015-01-21 10:07:35 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-01-29 10:37:53 +0000
commit56142f002046d319a2cdc326ea8f8c0892f3061f (patch)
tree2afcabac2fda74e3c0f29c133787a182964834e9
parentc992868a989926eac6c4b78a6bb9729bce54f2ed (diff)
downloadopenembedded-core-contrib-56142f002046d319a2cdc326ea8f8c0892f3061f.tar.gz
linux-dummy: provide empty shared_workdir method
Perf.bb (among others) requires access to the kernel source, so have linux-dummy fake that as well. As before, perf will fail to build, but there are use cases where this patch is needed. For example a perf.bbappend that will always build it from the debian linux-tools tarball. Using linux-dummy is still a bad, bad idea, but it shouldn't start breaking existing use cases. Signed-off-by: Koen Kooi <koen.kooi@linaro.org> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-kernel/linux/linux-dummy.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-kernel/linux/linux-dummy.bb b/meta/recipes-kernel/linux/linux-dummy.bb
index 8f25f17e6f..cc0e4e64a9 100644
--- a/meta/recipes-kernel/linux/linux-dummy.bb
+++ b/meta/recipes-kernel/linux/linux-dummy.bb
@@ -33,6 +33,10 @@ do_compile () {
:
}
+do_shared_workdir () {
+ :
+}
+
do_install() {
:
}
@@ -47,4 +51,4 @@ do_deploy() {
addtask bundle_initramfs after do_install before do_deploy
addtask deploy after do_install
-
+addtask shared_workdir after do_compile before do_install