aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2017-09-14 09:46:58 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-09-14 16:38:43 +0100
commit3c60106d86b79c9350102ddf2a904876840b458a (patch)
treec30fb555d485dc1f4ec22a42cdd5b902a33b8811
parent57819c9f133f168a6a856afa0d0c5ac57a4f2f44 (diff)
downloadopenembedded-core-contrib-3c60106d86b79c9350102ddf2a904876840b458a.tar.gz
linux-yocto/4.12: integrate aufs4 core support
The aufs4 now has a 4.12 port, so we can integrate it into the reference kernel and stay consistent with previous releases. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.12.bb18
3 files changed, 13 insertions, 13 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb
index f19e1248a9..491e5b05a2 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb
@@ -11,8 +11,8 @@ python () {
raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}
-SRCREV_machine ?= "873830670b1af7765428166db40d413018c40e28"
-SRCREV_meta ?= "4fdd56fe602ceb2690407df44283e45ff1c9cd0e"
+SRCREV_machine ?= "c86fccf85be960294703ca9882dde9ee62aaa9e4"
+SRCREV_meta ?= "eda4d18ce4b259c84ccd5c249c3dc5958c16928c"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.12.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.12;destsuffix=${KMETA}"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb
index fa3cd2075b..05debd338b 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb
@@ -9,8 +9,8 @@ LINUX_VERSION ?= "4.12.12"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine ?= "873830670b1af7765428166db40d413018c40e28"
-SRCREV_meta ?= "4fdd56fe602ceb2690407df44283e45ff1c9cd0e"
+SRCREV_machine ?= "c86fccf85be960294703ca9882dde9ee62aaa9e4"
+SRCREV_meta ?= "eda4d18ce4b259c84ccd5c249c3dc5958c16928c"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.12.bb b/meta/recipes-kernel/linux/linux-yocto_4.12.bb
index e9838247f4..d060e2496b 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.12.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.12.bb
@@ -11,15 +11,15 @@ KBRANCH_qemux86 ?= "standard/base"
KBRANCH_qemux86-64 ?= "standard/base"
KBRANCH_qemumips64 ?= "standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "1f5c932260cac2118d256d38b475a2811a8551e5"
-SRCREV_machine_qemuarm64 ?= "873830670b1af7765428166db40d413018c40e28"
-SRCREV_machine_qemumips ?= "a9f98cc2715a65537877c86808a101429028d48b"
-SRCREV_machine_qemuppc ?= "873830670b1af7765428166db40d413018c40e28"
-SRCREV_machine_qemux86 ?= "873830670b1af7765428166db40d413018c40e28"
-SRCREV_machine_qemux86-64 ?= "873830670b1af7765428166db40d413018c40e28"
-SRCREV_machine_qemumips64 ?= "1863c93b44aeb6badb4993fd9a6ab3d360bf30d1"
-SRCREV_machine ?= "873830670b1af7765428166db40d413018c40e28"
-SRCREV_meta ?= "4fdd56fe602ceb2690407df44283e45ff1c9cd0e"
+SRCREV_machine_qemuarm ?= "42a4ca618610964560fcf6e4b6d7540f5449e992"
+SRCREV_machine_qemuarm64 ?= "c86fccf85be960294703ca9882dde9ee62aaa9e4"
+SRCREV_machine_qemumips ?= "9252e9261b0a606df2f3f49004c23f8a110962ad"
+SRCREV_machine_qemuppc ?= "c86fccf85be960294703ca9882dde9ee62aaa9e4"
+SRCREV_machine_qemux86 ?= "c86fccf85be960294703ca9882dde9ee62aaa9e4"
+SRCREV_machine_qemux86-64 ?= "c86fccf85be960294703ca9882dde9ee62aaa9e4"
+SRCREV_machine_qemumips64 ?= "bbcf4a8ae8af56687938a7412a9da92f4d1b6552"
+SRCREV_machine ?= "c86fccf85be960294703ca9882dde9ee62aaa9e4"
+SRCREV_meta ?= "eda4d18ce4b259c84ccd5c249c3dc5958c16928c"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.12.git;name=machine;branch=${KBRANCH}; \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.12;destsuffix=${KMETA}"