aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-07-18 19:50:55 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-07-24 09:12:25 +0100
commit470c8a0fb5f51a626a194c8fd3aabd448b50ebfa (patch)
treec11b0c9b6f44f98f240b502a88d81b979c16c92c
parent4e4c96db4b1d2356b5d071cee6746a96eca20439 (diff)
downloadopenembedded-core-contrib-470c8a0fb5f51a626a194c8fd3aabd448b50ebfa.tar.gz
mkelfimage: Fix build on x86_64 with hardening
We get linking errors on some hosts like | ld -static --warn-multiple-gp --warn-common -T linux-i386/convert.lds -o objdir/linux-i386/convert ob jdir/linux-i386/head.o objdir/linux-i386/convert_params.o | objdir/linux-i386/convert_params.o: In function `printf': | convert_params.c:(.text+0x1fd): undefined reference to `__stack_chk_fail_local' This is because the build system is defaulting to host linker when building 32bit binaries and it may not have same defaults as OE toolchain and issue gets highlighted. fix it by using cross linker for 32bit links when building on x86_64 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/mkelfimage/mkelfimage_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb b/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb
index 2bcc8d7bd9..2ad4b49ab1 100644
--- a/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb
+++ b/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb
@@ -29,6 +29,7 @@ CACHED_CONFIGUREVARS += "\
HOST_CFLAGS='${BUILD_CFLAGS}' \
HOST_CPPFLAGS='${BUILD_CPPFLAGS}' \
"
+EXTRA_OECONF_append_x86-64 = " --with-i386=${HOST_SYS}"
inherit autotools-brokensep