summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2022-01-07 14:32:19 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-01-07 23:10:22 +0000
commitf30ebc0b82b10f56f250a3a9c4f1f2fe9fb281b3 (patch)
tree27c8f963172b333262ac53054beb7663cd34494f
parentc00f79c2f1b8a939e9a19e641c49aa759dd3a342 (diff)
downloadopenembedded-core-contrib-f30ebc0b82b10f56f250a3a9c4f1f2fe9fb281b3.tar.gz
libsdl2: Fix X11 configure options
We're seeing various failures where the X11 headers are found on the native system but not all libraries are present and hence autoconfiguration of the X11 subcomponents fails. We don't list any of these X11 subcomponents as a dependency so disable them by default. Configuration and dependencies can be added if people need them. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/libsdl2/libsdl2_2.0.18.bb11
1 files changed, 10 insertions, 1 deletions
diff --git a/meta/recipes-graphics/libsdl2/libsdl2_2.0.18.bb b/meta/recipes-graphics/libsdl2/libsdl2_2.0.18.bb
index 20e4942835..893386343a 100644
--- a/meta/recipes-graphics/libsdl2/libsdl2_2.0.18.bb
+++ b/meta/recipes-graphics/libsdl2/libsdl2_2.0.18.bb
@@ -37,7 +37,16 @@ EXTRA_OECMAKE = "-DSDL_OSS=OFF -DSDL_ESD=OFF -DSDL_ARTS=OFF \
-DSDL_PTHREADS=ON \
-DSDL_RPATH=OFF \
-DSDL_SNDIO=OFF \
- "
+ -DSDL_X11_XVM=OFF \
+ -DSDL_X11_XCURSOR=OFF \
+ -DSDL_X11_XINERAMA=OFF \
+ -DSDL_X11_XDBE=OFF \
+ -DSDL_X11_XFIXES=OFF \
+ -DSDL_X11_XINPUT=OFF \
+ -DSDL_X11_XRANDR=OFF \
+ -DSDL_X11_XSCRNSAVER=OFF \
+ -DSDL_X11_XSHAPE=OFF \
+"
# opengl packageconfig factored out to make it easy for distros
# and BSP layers to pick either (desktop) opengl, gles2, or no GL