aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-05-17 21:40:22 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-19 08:39:27 +0100
commit074bf42d72ee2f5b155814eb24d52e06e2cebb9e (patch)
tree4e5db757330d5202181c35d36e8f147e753387ee
parent342701f25db0943fb1038ac3741a1feaab8458fd (diff)
downloadopenembedded-core-contrib-074bf42d72ee2f5b155814eb24d52e06e2cebb9e.tar.gz
pixman: Fix build on arches not defining FE_INVALID exception
Nios2 e.g. only supports round to nearest in glibc Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/xorg-lib/pixman/0001-test-utils-Check-for-FE_INVALID-definition-before-us.patch33
-rw-r--r--meta/recipes-graphics/xorg-lib/pixman_0.34.0.bb1
2 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-lib/pixman/0001-test-utils-Check-for-FE_INVALID-definition-before-us.patch b/meta/recipes-graphics/xorg-lib/pixman/0001-test-utils-Check-for-FE_INVALID-definition-before-us.patch
new file mode 100644
index 0000000000..782c1db022
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/pixman/0001-test-utils-Check-for-FE_INVALID-definition-before-us.patch
@@ -0,0 +1,33 @@
+From 0ccd906b904d21536d5ab41c6196760e3e5d72cb Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 17 May 2016 17:30:00 -0700
+Subject: [PATCH] test/utils: Check for FE_INVALID definition before use
+
+Some architectures e.g. nios2 do not support all exceptions
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+Upstream-Status: Submitted
+
+ test/utils.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/test/utils.c b/test/utils.c
+index f8e42a5..fe32b1e 100644
+--- a/test/utils.c
++++ b/test/utils.c
+@@ -978,9 +978,11 @@ enable_invalid_exceptions (void)
+ {
+ #ifdef HAVE_FENV_H
+ #ifdef HAVE_FEENABLEEXCEPT
++#ifdef FE_INVALID
+ feenableexcept (FE_INVALID);
+ #endif
+ #endif
++#endif
+ }
+
+ void *
+--
+2.8.2
+
diff --git a/meta/recipes-graphics/xorg-lib/pixman_0.34.0.bb b/meta/recipes-graphics/xorg-lib/pixman_0.34.0.bb
index 87da5c2abc..c4ca621a8a 100644
--- a/meta/recipes-graphics/xorg-lib/pixman_0.34.0.bb
+++ b/meta/recipes-graphics/xorg-lib/pixman_0.34.0.bb
@@ -32,6 +32,7 @@ EXTRA_OECONF_class-nativesdk = "--disable-gtk"
SRC_URI += "\
file://0001-ARM-qemu-related-workarounds-in-cpu-features-detecti.patch \
file://asm_include.patch \
+ file://0001-test-utils-Check-for-FE_INVALID-definition-before-us.patch \
"
SRC_URI[md5sum] = "002a4fcb644ddfcb4b0e4191576a0d59"