aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2017-07-24 18:58:25 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-07-30 08:45:11 +0100
commit98fba18e93abe8efce0a5b40d51e178c9de4d1e5 (patch)
treecd800bdaa118bac636c1f96fbcf9fafd8a3ad793
parent4c2276469f58a88f864eb374c00dbbaace702de4 (diff)
downloadopenembedded-core-contrib-98fba18e93abe8efce0a5b40d51e178c9de4d1e5.tar.gz
systemtap: ensure systemtap-native is available
Since we are adding the addto_sysroot that that is specific to the native recipe, we must split this into a seperate -native .bb recipe. When systemtap-native is built, the intention is that it's usable from the native sysroot when done, ensure it's there with a forced addto_recipe_sysroot task, we also don't want to clean the sysroot when RM_WORK is enabled otherwise we loose the binaries. [YOCTO #11403] Signed-off-by: Saul Wold <sgw@linux.intel.com> (cherry picked from commit 2fdb59741b4fdeaa4aee10812c4a409cdc11a02d) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/systemtap/systemtap-native_git.bb7
-rw-r--r--meta/recipes-kernel/systemtap/systemtap_git.bb2
2 files changed, 8 insertions, 1 deletions
diff --git a/meta/recipes-kernel/systemtap/systemtap-native_git.bb b/meta/recipes-kernel/systemtap/systemtap-native_git.bb
new file mode 100644
index 0000000000..c3da77c831
--- /dev/null
+++ b/meta/recipes-kernel/systemtap/systemtap-native_git.bb
@@ -0,0 +1,7 @@
+
+require systemtap_git.bb
+
+inherit native
+
+RM_WORK_EXCLUDE_ITEMS += "recipe-sysroot-native"
+addtask addto_recipe_sysroot after do_populate_sysroot before do_build
diff --git a/meta/recipes-kernel/systemtap/systemtap_git.bb b/meta/recipes-kernel/systemtap/systemtap_git.bb
index fed368a38b..b3fd9730da 100644
--- a/meta/recipes-kernel/systemtap/systemtap_git.bb
+++ b/meta/recipes-kernel/systemtap/systemtap_git.bb
@@ -25,4 +25,4 @@ PACKAGECONFIG[python3-probes] = "--with-python3-probes,--without-python3-probes,
inherit autotools gettext pkgconfig distutils3-base
-BBCLASSEXTEND = "native nativesdk"
+BBCLASSEXTEND = "nativesdk"