summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-12-02 18:09:17 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-12-04 12:29:29 +0000
commit33d9d696f3a865a51c0a16a0a65a8028642be4d7 (patch)
tree69a3ce8406ebfdfdae6940f0011aea12a1a8c823
parentbd40260cbacf660e7390f4f5ef5e096e75774b05 (diff)
downloadopenembedded-core-contrib-33d9d696f3a865a51c0a16a0a65a8028642be4d7.tar.gz
python-numpy: upgrade to 1.17.4
Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python-numpy/files/0001-npy_cpu-Add-riscv-support.patch24
-rw-r--r--meta/recipes-devtools/python-numpy/files/0001-numpy-random-setup.py-remove-the-detection-of-x86-ta.patch4
-rw-r--r--meta/recipes-devtools/python-numpy/python-numpy.inc5
-rw-r--r--meta/recipes-devtools/python-numpy/python3-numpy_1.17.4.bb (renamed from meta/recipes-devtools/python-numpy/python3-numpy_1.17.0.bb)0
4 files changed, 4 insertions, 29 deletions
diff --git a/meta/recipes-devtools/python-numpy/files/0001-npy_cpu-Add-riscv-support.patch b/meta/recipes-devtools/python-numpy/files/0001-npy_cpu-Add-riscv-support.patch
deleted file mode 100644
index 4decfe66ee..0000000000
--- a/meta/recipes-devtools/python-numpy/files/0001-npy_cpu-Add-riscv-support.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 629891f67601275c9c4de0bb01afcf1a8c44fa3f Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Fri, 16 Mar 2018 19:55:21 -0700
-Subject: [PATCH] npy_cpu: Add riscv support
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-Upstream-Status: Submitted [https://github.com/numpy/numpy/pull/10761]
----
- numpy/core/include/numpy/npy_cpu.h | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/numpy/core/include/numpy/npy_cpu.h b/numpy/core/include/numpy/npy_cpu.h
-index 5edd8f4..e1e4796 100644
---- a/numpy/core/include/numpy/npy_cpu.h
-+++ b/numpy/core/include/numpy/npy_cpu.h
-@@ -96,6 +96,8 @@
- #define NPY_CPU_OR1K
- #elif defined(__mc68000__)
- #define NPY_CPU_M68K
-+#elif defined(__riscv)
-+ #define NPY_CPU_RISCV
- #elif defined(__arc__) && defined(__LITTLE_ENDIAN__)
- #define NPY_CPU_ARCEL
- #elif defined(__arc__) && defined(__BIG_ENDIAN__)
diff --git a/meta/recipes-devtools/python-numpy/files/0001-numpy-random-setup.py-remove-the-detection-of-x86-ta.patch b/meta/recipes-devtools/python-numpy/files/0001-numpy-random-setup.py-remove-the-detection-of-x86-ta.patch
index ebb2a6f9df..9da6a2b3da 100644
--- a/meta/recipes-devtools/python-numpy/files/0001-numpy-random-setup.py-remove-the-detection-of-x86-ta.patch
+++ b/meta/recipes-devtools/python-numpy/files/0001-numpy-random-setup.py-remove-the-detection-of-x86-ta.patch
@@ -22,8 +22,8 @@ index a1bf3b8..60fb534 100644
elif not is_msvc:
# Some bit generators require c99
EXTRA_COMPILE_ARGS += ['-std=c99']
-- INTEL_LIKE = any([val in k.lower() for k in platform.uname()
-- for val in ('x86', 'i686', 'i386', 'amd64')])
+- INTEL_LIKE = any(arch in platform.machine()
+- for arch in ('x86', 'i686', 'i386', 'amd64'))
- if INTEL_LIKE:
- # Assumes GCC or GCC-like compiler
- EXTRA_COMPILE_ARGS += ['-msse2']
diff --git a/meta/recipes-devtools/python-numpy/python-numpy.inc b/meta/recipes-devtools/python-numpy/python-numpy.inc
index f68b90e6b9..8413434af9 100644
--- a/meta/recipes-devtools/python-numpy/python-numpy.inc
+++ b/meta/recipes-devtools/python-numpy/python-numpy.inc
@@ -7,11 +7,10 @@ SRCNAME = "numpy"
SRC_URI = "https://github.com/${SRCNAME}/${SRCNAME}/releases/download/v${PV}/${SRCNAME}-${PV}.tar.gz \
file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \
- file://0001-npy_cpu-Add-riscv-support.patch \
file://0001-numpy-random-setup.py-remove-the-detection-of-x86-ta.patch \
"
-SRC_URI[md5sum] = "c48b2ad785f82cdfe28c907ce35e2a71"
-SRC_URI[sha256sum] = "47b7b6145e7ba5918ce26be25999b6d4b35cf9fbfdf46b7da50090ffdb020445"
+SRC_URI[md5sum] = "9147c3ee75e58d657b5b8b5a4f3564e0"
+SRC_URI[sha256sum] = "fb0415475e673cb9a6dd816df999e0ab9f86fa3af2b1770944e7288d2bea4ac9"
UPSTREAM_CHECK_URI = "https://github.com/numpy/numpy/releases"
UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
diff --git a/meta/recipes-devtools/python-numpy/python3-numpy_1.17.0.bb b/meta/recipes-devtools/python-numpy/python3-numpy_1.17.4.bb
index d388e88d25..d388e88d25 100644
--- a/meta/recipes-devtools/python-numpy/python3-numpy_1.17.0.bb
+++ b/meta/recipes-devtools/python-numpy/python3-numpy_1.17.4.bb