aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2017-04-25 17:07:08 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-05-10 12:21:34 +0100
commit43f7652baa0f1973477731ce05786eda2cc81c09 (patch)
treeef4f5d0e4646a7dabda9f5672db545f2df1e600f
parent1160b51fbe5661be83959c0e135e4b4231c94349 (diff)
downloadopenembedded-core-contrib-43f7652baa0f1973477731ce05786eda2cc81c09.tar.gz
libcap: clean up gperf enabling logic
There's no need to sed the Makefile (especially the wrong Makefile) when there's a variable we can pass. Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-support/libcap/libcap_2.25.bb4
1 files changed, 1 insertions, 3 deletions
diff --git a/meta/recipes-support/libcap/libcap_2.25.bb b/meta/recipes-support/libcap/libcap_2.25.bb
index 0587e77e98..5c2765f343 100644
--- a/meta/recipes-support/libcap/libcap_2.25.bb
+++ b/meta/recipes-support/libcap/libcap_2.25.bb
@@ -22,9 +22,6 @@ do_configure() {
# on what should be replaced with ?=
sed -e 's,:=,?=,g' -i Make.Rules
sed -e 's,^BUILD_CFLAGS ?= $(.*CFLAGS),BUILD_CFLAGS := $(BUILD_CFLAGS),' -i Make.Rules
-
- # disable gperf detection
- sed -e '/shell gperf/cifeq (,yes)' -i libcap/Makefile
}
PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}"
@@ -37,6 +34,7 @@ EXTRA_OEMAKE = " \
lib=${@os.path.basename('${libdir}')} \
RAISE_SETFCAP=no \
DYNAMIC=yes \
+ BUILD_GPERF=yes \
"
EXTRA_OEMAKE_append_class-target = " SYSTEM_HEADERS=${STAGING_INCDIR}"