aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuro Bystricky <juro.bystricky@intel.com>2017-11-22 13:58:29 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-12-02 11:24:37 +0000
commitd4ac52bef9f5364619fcb8e2f8c05927d660fff7 (patch)
tree7408c049916a7f496bb914ebab6db70ca0db66d3
parent7725bad91b89a291a7099b2d99789a86b028f329 (diff)
downloadopenembedded-core-contrib-d4ac52bef9f5364619fcb8e2f8c05927d660fff7.tar.gz
ltp: improve reproducibility
ltp package contains several gzipped files. Improve reproducibility of the build by ensuring the gzipped files do not contain timestamps in their headers. https://wiki.debian.org/ReproducibleBuilds/TimestampsInGzipHeaders Signed-off-by: Juro Bystricky <juro.bystricky@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-extended/ltp/ltp/0038-generate-reproducible-gzip.patch20
-rw-r--r--meta/recipes-extended/ltp/ltp_20170929.bb1
2 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-extended/ltp/ltp/0038-generate-reproducible-gzip.patch b/meta/recipes-extended/ltp/ltp/0038-generate-reproducible-gzip.patch
new file mode 100644
index 0000000000..0153ace8ea
--- /dev/null
+++ b/meta/recipes-extended/ltp/ltp/0038-generate-reproducible-gzip.patch
@@ -0,0 +1,20 @@
+Do not generate timestamps in gzipped file headers.
+The timestamps prevent reproducible build.
+
+Upstream-Status: Submitted [https://github.com/linux-test-project/ltp/pull/233]
+
+Signed-off-by: Juro Bystricky <juro.bystricky@intel.com>
+
+diff --git a/testcases/network/generate.sh b/testcases/network/generate.sh
+index 00216a6..939f792 100755
+--- a/testcases/network/generate.sh
++++ b/testcases/network/generate.sh
+@@ -55,7 +55,7 @@ fi
+ if [ ! -e "bin.sm" ] ; then
+ cnt=0
+ while [ $cnt -lt 5 ] ; do
+- gzip -1 -c ascii.sm >> "bin.sm"
++ gzip -1 -c -n ascii.sm >> "bin.sm"
+ cnt=$(($cnt + 1))
+ done
+ fi
diff --git a/meta/recipes-extended/ltp/ltp_20170929.bb b/meta/recipes-extended/ltp/ltp_20170929.bb
index 93a59b31bd..8a870b36ac 100644
--- a/meta/recipes-extended/ltp/ltp_20170929.bb
+++ b/meta/recipes-extended/ltp/ltp_20170929.bb
@@ -49,6 +49,7 @@ SRC_URI = "git://github.com/linux-test-project/ltp.git \
file://0035-fix-test_proc_kill-hang.patch \
file://0036-testcases-network-nfsv4-acl-acl1.c-Security-fix-on-s.patch \
file://0037-ltp-fix-format-security-error.patch \
+ file://0038-generate-reproducible-gzip.patch \
"
S = "${WORKDIR}/git"