aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2015-08-26 18:10:45 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-09-02 23:46:05 +0100
commit0c4498878df352b9dbaa118c3cc201454ac22154 (patch)
treeb7ceb1adcdbe9ccbf00dc14e139492fe5c0f7671
parentea04f05710a9a2a1e9561fe87579d0ae9690bd21 (diff)
downloadopenembedded-core-contrib-0c4498878df352b9dbaa118c3cc201454ac22154.tar.gz
mtd-utils: add xattr PACKAGECONFIG and fix acl dependency
The unconditional removal of -DWITHOUT_XATTR accidentally introduced a compile-time dependency on "acl", because "sys/acl.h" gets included. This caused random compile failures. To fix this, we introduce a proper PACKAGECONFIG for the "xattr" support, with the distro's "xattr" feature determining the default. Setting the define must be done with custom code because PACKAGECONFIG can only influence configure parameters. The "acl" distro feature is not checked because although enabling "xattr" support now triggers a build of acl, nothing from it will not get included in the resulting target image. This seems more suitable than not enabling xattr support in mtd-utils when acl support in the distro is disabled. Signed-off-by: Patrick Ohly <patrick.ohly@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/mtd/mtd-utils_git.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-devtools/mtd/mtd-utils_git.bb b/meta/recipes-devtools/mtd/mtd-utils_git.bb
index 8d4892a0d4..17dca77609 100644
--- a/meta/recipes-devtools/mtd/mtd-utils_git.bb
+++ b/meta/recipes-devtools/mtd/mtd-utils_git.bb
@@ -19,7 +19,13 @@ SRC_URI = "git://git.infradead.org/mtd-utils.git \
S = "${WORKDIR}/git/"
-EXTRA_OEMAKE = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include' 'BUILDDIR=${S}'"
+# xattr support creates an additional compile-time dependency on acl because
+# the sys/acl.h header is needed. libacl is not needed and thus enabling xattr
+# regardless whether acl is enabled or disabled in the distro should be okay.
+PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'xattr', '', d)}"
+PACKAGECONFIG[xattr] = ",,acl,"
+
+EXTRA_OEMAKE = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} ${@bb.utils.contains('PACKAGECONFIG', 'xattr', '', '-DWITHOUT_XATTR', d)} -I${S}/include' 'BUILDDIR=${S}'"
do_install () {
oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} INCLUDEDIR=${includedir}