aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2017-12-21 10:49:18 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-12-21 16:26:36 +0000
commit70f3d81e414a101032c05773c33500e7d723ab02 (patch)
tree9bbde0ec70fdc932ff35c248390e37defa553958
parentd3a8565e176ad77a99b832caf5e23b62846a9a67 (diff)
downloadopenembedded-core-contrib-70f3d81e414a101032c05773c33500e7d723ab02.tar.gz
linux-yocto-dev: update to v4.15+
Outside of the normal patch refreshes and boot issues, there are new build time tools within the kernel that required the following dependencies: For ORC_UNWINDER support in x86-64: DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}" And for certificate processing during the build, we need ssl headers and hexdump: DEPENDS += "openssl-native util-linux-native" Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-dev.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-dev.bb b/meta/recipes-kernel/linux/linux-yocto-dev.bb
index 6876ab7071..490b83af68 100644
--- a/meta/recipes-kernel/linux/linux-yocto-dev.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-dev.bb
@@ -28,10 +28,13 @@ SRC_URI = "git://git.yoctoproject.org/linux-yocto-dev.git;branch=${KBRANCH};name
SRCREV_machine ?= '${@oe.utils.conditional("PREFERRED_PROVIDER_virtual/kernel", "linux-yocto-dev", "${AUTOREV}", "29594404d7fe73cd80eaa4ee8c43dcc53970c60e", d)}'
SRCREV_meta ?= '${@oe.utils.conditional("PREFERRED_PROVIDER_virtual/kernel", "linux-yocto-dev", "${AUTOREV}", "29594404d7fe73cd80eaa4ee8c43dcc53970c60e", d)}'
-LINUX_VERSION ?= "4.14-rc+"
+LINUX_VERSION ?= "4.15-rc+"
LINUX_VERSION_EXTENSION ?= "-yoctodev-${LINUX_KERNEL_TYPE}"
PV = "${LINUX_VERSION}+git${SRCPV}"
+DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
+DEPENDS += "openssl-native util-linux-native"
+
COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemumips64|qemux86-64)"
KERNEL_DEVICETREE_qemuarm = "versatile-pb.dtb"