aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2017-11-29 12:31:55 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-12-09 14:36:58 +0000
commitd58c20fd45f4808cbc1726ec5b46edb1c60b9cf8 (patch)
treeec15d8f6983a8c46b18137e44383acf89e454cae
parent8f9025f05b787f41f1867d340d911d7754ee7794 (diff)
downloadopenembedded-core-contrib-d58c20fd45f4808cbc1726ec5b46edb1c60b9cf8.tar.gz
bash: fix build race under musl
Under musl bash uses its own libintl clone but there are some missing dependencies so it is possible for pathexp.o to be built whilst libintl.h is being written, leading to compile errors. Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-extended/bash/bash/pathexp-dep.patch13
-rw-r--r--meta/recipes-extended/bash/bash_4.4.bb1
2 files changed, 14 insertions, 0 deletions
diff --git a/meta/recipes-extended/bash/bash/pathexp-dep.patch b/meta/recipes-extended/bash/bash/pathexp-dep.patch
new file mode 100644
index 0000000000..e05bbda317
--- /dev/null
+++ b/meta/recipes-extended/bash/bash/pathexp-dep.patch
@@ -0,0 +1,13 @@
+pathexp includes libintl.h but doesn't depend on it, thus a build race can occur.
+
+Upstream-Status: Submitted (https://savannah.gnu.org/patch/index.php?9503)
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/Makefile.in b/Makefile.in
+index c7b62bc0..241cbf12 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -1281,2 +1281,3 @@ nojobs.o: bashintl.h ${LIBINTL_H} $(BASHINCDIR)/gettext.h
+ y.tab.o: bashintl.h ${LIBINTL_H} $(BASHINCDIR)/gettext.h
++pathexp.o: bashintl.h ${LIBINTL_H} $(BASHINCDIR)/gettext.h
+ pcomplete.o: bashintl.h ${LIBINTL_H} $(BASHINCDIR)/gettext.h
diff --git a/meta/recipes-extended/bash/bash_4.4.bb b/meta/recipes-extended/bash/bash_4.4.bb
index e544d07c10..8b989ed3bd 100644
--- a/meta/recipes-extended/bash/bash_4.4.bb
+++ b/meta/recipes-extended/bash/bash_4.4.bb
@@ -26,6 +26,7 @@ SRC_URI = "${GNU_MIRROR}/bash/${BP}.tar.gz;name=tarball \
file://fix-run-builtins.patch \
file://0001-help-fix-printf-format-security-warning.patch \
file://bash-memleak-bug-fix-for-builtin-command-read.patch \
+ file://pathexp-dep.patch \
"
SRC_URI[tarball.md5sum] = "148888a7c95ac23705559b6f477dfe25"