aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2017-12-04 10:39:20 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-12-10 22:41:43 +0000
commit195758b0a611e937af41880ad81c312de654c5b8 (patch)
tree71bea2817cf480ed5e881d4423ae8271c5d5ba62
parentf65220d326c0b288ba076054bfada433f359ae8b (diff)
downloadopenembedded-core-contrib-195758b0a611e937af41880ad81c312de654c5b8.tar.gz
linux-yocto/4.12: iwlwifi calltrace fixes and configuration warning cleanups
Merging the following upstream backports to fix a iwlwifi calltrace: 0b17e1b52f99 iwlwifi: mvm: support new flush API 89025056c0d1 iwlwifi: mvm: avoid variable shadowing d6dc077966e7 iwlwifi: mvm: add and use iwl_mvm_device_running() 5dfb593df8f0 iwlwifi: add wait for tx queue empty 0e8726bf748a iwlwifi: mvm: wait for the flushed queue only 8e2d37ae55a7 iwlwifi: mvm: flush per station for DQA mode Also merging the following configuration changes to cleanup kernel audit warnings: 9f1f122a7d87 features/dca/dca.cfg: fix CONFIG_IXGBE_DCA can not enble if build ixgbe in kernel d355f082c54d features/iommu/iommu.cfg: remove CONFIG_INTEL_IOMMU_DEFAULT_ON=n 9399ae045c72 features/tpm/tpm.cfg: set CONFIG_HW_RANDOM_TPM as module Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.12.bb18
3 files changed, 13 insertions, 13 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb
index 983c1cc758..abd25a87f8 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb
@@ -11,8 +11,8 @@ python () {
raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}
-SRCREV_machine ?= "2143b758ad622a73c7c0b3fc8890b81000187635"
-SRCREV_meta ?= "cebe198870d781829bd997a188cc34d9f7a61023"
+SRCREV_machine ?= "55000a68d7b8ba26ce1733d48f9efa384528e67c"
+SRCREV_meta ?= "b9735e238841b9932bb324e8b4d9fb536d812ed1"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.12.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.12;destsuffix=${KMETA}"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb
index 658ecc0d6d..68d5a8ad85 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb
@@ -9,8 +9,8 @@ LINUX_VERSION ?= "4.12.14"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine ?= "9cc6b0ae1aad7312e85ac4134398f81c0140de33"
-SRCREV_meta ?= "cebe198870d781829bd997a188cc34d9f7a61023"
+SRCREV_machine ?= "0b17e1b52f9953a5672890e478de94ac8c44775f"
+SRCREV_meta ?= "b9735e238841b9932bb324e8b4d9fb536d812ed1"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.12.bb b/meta/recipes-kernel/linux/linux-yocto_4.12.bb
index a7dd763513..a45d90bfaf 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.12.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.12.bb
@@ -11,15 +11,15 @@ KBRANCH_qemux86 ?= "standard/base"
KBRANCH_qemux86-64 ?= "standard/base"
KBRANCH_qemumips64 ?= "standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "03489013c6844bf3f911e51c5b8cd3bd5c1dc6e9"
-SRCREV_machine_qemuarm64 ?= "9cc6b0ae1aad7312e85ac4134398f81c0140de33"
-SRCREV_machine_qemumips ?= "c22264e2e3340eb8affa9a9fc0b86decb2be26c6"
-SRCREV_machine_qemuppc ?= "9cc6b0ae1aad7312e85ac4134398f81c0140de33"
-SRCREV_machine_qemux86 ?= "9cc6b0ae1aad7312e85ac4134398f81c0140de33"
-SRCREV_machine_qemux86-64 ?= "9cc6b0ae1aad7312e85ac4134398f81c0140de33"
-SRCREV_machine_qemumips64 ?= "ead3f1c16e85d1b1074acdd13084b5cdf1104e23"
-SRCREV_machine ?= "9cc6b0ae1aad7312e85ac4134398f81c0140de33"
-SRCREV_meta ?= "cebe198870d781829bd997a188cc34d9f7a61023"
+SRCREV_machine_qemuarm ?= "b6b85e6055b8af3ef9a8e74f4edb5c0a69bd031b"
+SRCREV_machine_qemuarm64 ?= "0b17e1b52f9953a5672890e478de94ac8c44775f"
+SRCREV_machine_qemumips ?= "788655446537fbf4a7c7cb720b4ea3dfa0ca9d20"
+SRCREV_machine_qemuppc ?= "0b17e1b52f9953a5672890e478de94ac8c44775f"
+SRCREV_machine_qemux86 ?= "0b17e1b52f9953a5672890e478de94ac8c44775f"
+SRCREV_machine_qemux86-64 ?= "0b17e1b52f9953a5672890e478de94ac8c44775f"
+SRCREV_machine_qemumips64 ?= "d3f5808a2f7787e02057df9fea1fa97fb939fd6c"
+SRCREV_machine ?= "0b17e1b52f9953a5672890e478de94ac8c44775f"
+SRCREV_meta ?= "b9735e238841b9932bb324e8b4d9fb536d812ed1"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.12.git;name=machine;branch=${KBRANCH}; \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.12;destsuffix=${KMETA}"