summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2021-12-08 16:13:21 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-12-12 11:27:20 +0000
commitde57b4624e3d2d66268c33c4bf86dcb25abcab32 (patch)
tree6c736d6a8fd9b380735c904cbf03da103dd1eff0
parent4903fdbace057df2e39c10aaef3440f89748eed2 (diff)
downloadopenembedded-core-contrib-de57b4624e3d2d66268c33c4bf86dcb25abcab32.tar.gz
libhandy: Backport a makefile header race
After the commit(8157ecc Separate public and private enums) introduced, there comes a race as below: | In file included from ../git/src/hdy-settings.c:11: | ../git/src/hdy-settings-private.h:16:10: fatal error: hdy-enums-private.h: No such file or directory | 16 | #include "hdy-enums-private.h" So also add private headers like private sources did now to libhandy_sources to fix the issue. Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-gnome/libhandy/libhandy/0001-Add-private-headers.patch37
-rw-r--r--meta/recipes-gnome/libhandy/libhandy_1.5.0.bb4
2 files changed, 40 insertions, 1 deletions
diff --git a/meta/recipes-gnome/libhandy/libhandy/0001-Add-private-headers.patch b/meta/recipes-gnome/libhandy/libhandy/0001-Add-private-headers.patch
new file mode 100644
index 0000000000..7b2a512738
--- /dev/null
+++ b/meta/recipes-gnome/libhandy/libhandy/0001-Add-private-headers.patch
@@ -0,0 +1,37 @@
+From e7c3e8fa00f6a68b2e0629db5ee115e641ea710e Mon Sep 17 00:00:00 2001
+From: Mingli Yu <mingli.yu@windriver.com>
+Date: Wed, 8 Dec 2021 07:35:52 +0000
+Subject: [PATCH] Add private headers
+
+After the commit(8157ecc Separate public and private enums) introduced,
+there comes a race as below:
+ | In file included from ../git/src/hdy-settings.c:11:
+ | ../git/src/hdy-settings-private.h:16:10: fatal error: hdy-enums-private.h: No such file or directory
+ | 16 | #include "hdy-enums-private.h"
+
+So also add private headers like private sources to libhandy_sources to
+fix the issue.
+
+Upstream-Status: Submitted [https://gitlab.gnome.org/GNOME/libhandy/-/merge_requests/796]
+
+Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
+---
+ src/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/meson.build b/src/meson.build
+index d087323..6f11f27 100644
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -64,7 +64,7 @@ hdy_private_enums = gnome.mkenums('hdy-enums-private',
+ )
+
+ libhandy_public_sources += [hdy_public_enums[0]]
+-libhandy_private_sources += [hdy_private_enums[0]]
++libhandy_private_sources += hdy_private_enums
+ libhandy_generated_headers += [hdy_public_enums[1]]
+
+ src_headers = [
+--
+2.32.0
+
diff --git a/meta/recipes-gnome/libhandy/libhandy_1.5.0.bb b/meta/recipes-gnome/libhandy/libhandy_1.5.0.bb
index d0b59b1a62..605ef2b5fa 100644
--- a/meta/recipes-gnome/libhandy/libhandy_1.5.0.bb
+++ b/meta/recipes-gnome/libhandy/libhandy_1.5.0.bb
@@ -9,7 +9,9 @@ BUGTRACKER = "https://gitlab.gnome.org/GNOME/libhandy/-/issues"
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
-SRC_URI = "git://gitlab.gnome.org/GNOME/libhandy.git;protocol=https;branch=master"
+SRC_URI = "git://gitlab.gnome.org/GNOME/libhandy.git;protocol=https;branch=master \
+ file://0001-Add-private-headers.patch \
+"
SRCREV = "8fa8306a79215fc6ebf2483145da98bf9b2495ab"
S = "${WORKDIR}/git"