summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYann Dirson <yann@blade-group.com>2020-11-12 18:26:12 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-11-13 14:31:56 +0000
commitddc82d153f19c6738ec2fa57fc2fe0c787a893f1 (patch)
treea0ed9373f0ad4110e5b41627d6b1c9ae31dcb610
parent2e753a12cf6bb98f9e0940e5ed6255ce8c538eed (diff)
downloadopenembedded-core-contrib-ddc82d153f19c6738ec2fa57fc2fe0c787a893f1.tar.gz
systemtap: split examples and python scripts out of main package
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/systemtap/systemtap_git.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/recipes-kernel/systemtap/systemtap_git.bb b/meta/recipes-kernel/systemtap/systemtap_git.bb
index 1c9f2aed16..e98aff1851 100644
--- a/meta/recipes-kernel/systemtap/systemtap_git.bb
+++ b/meta/recipes-kernel/systemtap/systemtap_git.bb
@@ -38,6 +38,23 @@ RDEPENDS_${PN}-exporter = "${PN} python3-core python3-netclient"
SYSTEMD_SERVICE_${PN}-exporter = "stap-exporter.service"
+PACKAGES =+ "${PN}-examples"
+FILES_${PN}-examples = "${datadir}/${BPN}/examples/"
+RDEPENDS_${PN}-examples += "${PN}"
+
+# don't complain that some examples involve bash, perl, php...
+INSANE_SKIP_${PN}-examples += "file-rdeps"
+
+PACKAGES =+ "${PN}-python"
+FILES_${PN}-python += "\
+ ${bindir}/dtrace \
+ ${libdir}/python*/ \
+ ${libexecdir}/${BPN}/python/ \
+"
+# python material requires sdt headers
+RDEPENDS_${PN}-python += "${PN}-dev python3-core"
+INSANE_SKIP_${PN}-python += "dev-deps"
+
do_configure_prepend () {
# Improve reproducibility for c++ object files
reltivepath="${@os.path.relpath(d.getVar('STAGING_INCDIR'), d.getVar('S'))}"