summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChaitanya Vadrevu <chaitanya.vadrevu@ni.com>2021-12-16 17:58:25 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-12-20 15:28:57 +0000
commit22e84cdd05870f1a19c6389b66c4dfd5e9b418f7 (patch)
tree7f26e92cab47c921605017e27e5ef3587356e4f0
parent774d49beb44b71009c5cfc4240189e808d6f45cb (diff)
downloadopenembedded-core-contrib-22e84cdd05870f1a19c6389b66c4dfd5e9b418f7.tar.gz
python3-pyelftools: Depend on debugger, pprint
python3-pyelftools uses python3-debugger, python3-pprint. So add dependencies on these packages. Signed-off-by: Chaitanya Vadrevu <chaitanya.vadrevu@ni.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python3-pyelftools_0.27.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pyelftools_0.27.bb b/meta/recipes-devtools/python/python3-pyelftools_0.27.bb
index 0cfd99504b..e2d0e18277 100644
--- a/meta/recipes-devtools/python/python3-pyelftools_0.27.bb
+++ b/meta/recipes-devtools/python/python3-pyelftools_0.27.bb
@@ -11,3 +11,5 @@ PYPI_PACKAGE = "pyelftools"
inherit pypi setuptools3
BBCLASSEXTEND = "native"
+
+RDEPENDS:${PN} += "${PYTHON_PN}-debugger ${PYTHON_PN}-pprint"