summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2020-06-04 16:13:39 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-06-04 13:42:01 +0100
commit115791844124bdddfbaec9d75bb887ef35c41f20 (patch)
tree70aabe3f305f79782a533a6858bc4b645b6d9d64
parent4bb87c8b28b58a469c01f4a051361aa099cdfe1a (diff)
downloadopenembedded-core-contrib-115791844124bdddfbaec9d75bb887ef35c41f20.tar.gz
python3-magic: add the missing rdepends
Add the missing rdepends to fix below error: # python3 [snip] >>> import magic [snip] ModuleNotFoundError: No module named 'ctypes' ModuleNotFoundError: No module named 'tempfile' Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python3-magic_0.4.18.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3-magic_0.4.18.bb b/meta/recipes-devtools/python/python3-magic_0.4.18.bb
index be423adacd..101b96d31c 100644
--- a/meta/recipes-devtools/python/python3-magic_0.4.18.bb
+++ b/meta/recipes-devtools/python/python3-magic_0.4.18.bb
@@ -14,6 +14,9 @@ inherit pypi setuptools3
SRC_URI[md5sum] = "5edc6caa39cc62641850f6b1b6f284ba"
SRC_URI[sha256sum] = "b757db2a5289ea3f1ced9e60f072965243ea43a2221430048fd8cacab17be0ce"
-RDEPENDS_${PN} += "file"
+RDEPENDS_${PN} += "file \
+ ${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-shell"
BBCLASSEXTEND = "native"