summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2020-06-16 09:51:06 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-06-17 11:09:27 +0100
commit9a2386443af23d4b713b9635a0275165565ef8f4 (patch)
treeed66c3f1c92fbd1817fbe6282560d82dbc9162cb
parentc3070d3b2e31a31fc32294972e7a3fae46b6e70f (diff)
downloadopenembedded-core-contrib-9a2386443af23d4b713b9635a0275165565ef8f4.tar.gz
iptables: split iptables-apply to its own package
We do not want iptables to depend on bash. So move iptables-apply/ip6tables-apply to a separate package. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/iptables/iptables_1.8.5.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-extended/iptables/iptables_1.8.5.bb b/meta/recipes-extended/iptables/iptables_1.8.5.bb
index 8664a9751a..5976128807 100644
--- a/meta/recipes-extended/iptables/iptables_1.8.5.bb
+++ b/meta/recipes-extended/iptables/iptables_1.8.5.bb
@@ -68,7 +68,7 @@ do_install_append() {
fi
}
-PACKAGES += "${PN}-modules"
+PACKAGES =+ "${PN}-modules ${PN}-apply"
PACKAGES_DYNAMIC += "^${PN}-module-.*"
python populate_packages_prepend() {
@@ -98,6 +98,9 @@ RRECOMMENDS_${PN} = " \
FILES_${PN} += "${datadir}/xtables"
+FILES_${PN}-apply = "${sbindir}/ip*-apply"
+RDEPENDS_${PN}-apply = "${PN} bash"
+
# Include the symlinks as well in respective packages
FILES_${PN}-module-xt-conntrack += "${libdir}/xtables/libxt_state.so"
FILES_${PN}-module-xt-ct += "${libdir}/xtables/libxt_NOTRACK.so"