aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2017-01-30 22:59:50 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-02-05 09:20:20 +0000
commit68aad8d179161c5fec75bf311060d829e4346c9f (patch)
tree5ad79e303c57c71d8c6e60c575f2c2f50fa00e89
parent66c282541a13f2d1224d3ba933a953c0f613fb2a (diff)
downloadopenembedded-core-contrib-68aad8d179161c5fec75bf311060d829e4346c9f.tar.gz
ffmpeg: disable cpu autodetection
Just pass the correct -mcpu= configure switch (fallback to generic). Avoids warnings like: | warning: switch -mcpu=cortex-a15 conflicts with -march=armv7-a switch Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-multimedia/ffmpeg/ffmpeg_3.2.2.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/ffmpeg/ffmpeg_3.2.2.bb b/meta/recipes-multimedia/ffmpeg/ffmpeg_3.2.2.bb
index 66718c4b37..c376d82dfc 100644
--- a/meta/recipes-multimedia/ffmpeg/ffmpeg_3.2.2.bb
+++ b/meta/recipes-multimedia/ffmpeg/ffmpeg_3.2.2.bb
@@ -66,6 +66,12 @@ PACKAGECONFIG[xv] = "--enable-outdev=xv,--disable-outdev=xv,libxv"
# Check codecs that require --enable-nonfree
USE_NONFREE = "${@bb.utils.contains_any('PACKAGECONFIG', [ 'openssl' ], 'yes', '', d)}"
+def cpu(d):
+ for arg in (d.getVar('TUNE_CCARGS') or '').split():
+ if arg.startswith('-mcpu='):
+ return arg[6:]
+ return 'generic'
+
EXTRA_OECONF = " \
--disable-stripping \
--enable-pic \
@@ -90,6 +96,7 @@ EXTRA_OECONF = " \
--shlibdir=${libdir} \
--datadir=${datadir}/ffmpeg \
${@bb.utils.contains('AVAILTUNES', 'mips32r2', '', '--disable-mipsdsp --disable-mipsdspr2', d)} \
+ --cpu=${@cpu(d)} \
"
EXTRA_OECONF_append_linux-gnux32 = " --disable-asm"