aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-10-04 23:03:48 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-10-05 10:11:16 +0100
commiteb4b39d5ffbe93d363b05c57196bdac61fa09c59 (patch)
tree3dade03ea48f67613199f849dbf9a0def31eaf3d
parent839b17ffd96abff3e9cf47fb4a6d680637c865b1 (diff)
downloadopenembedded-core-contrib-eb4b39d5ffbe93d363b05c57196bdac61fa09c59.tar.gz
linux-yocto/4.8: fix BUG_ON() in workingset_node_shadows_dec() triggers
Paul Gotmaker pointed out that a last minute merge to the 4.8 kernel has the potential to hard hang a kernel when VM debugging is enabled: https://lkml.org/lkml/2016/10/4/1 He also pointed out the fix for it in commit 21f54dda [Using BUG_ON() as an assert() is _never_ acceptable]. While that fix will loop through -stable into 4.8.1, that will likely be too late for our release. So I've cherry picked the change to make it available. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.8.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.8.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.8.bb16
3 files changed, 10 insertions, 10 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.8.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.8.bb
index 515f8783e9..90e1a4d747 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.8.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.8.bb
@@ -11,7 +11,7 @@ python () {
raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}
-SRCREV_machine ?= "cd97b2cf4bc73316204a5148d2b0f5fc5d2ecc19"
+SRCREV_machine ?= "b266f7ba78f0cb3d7073e1bf7bd7dfc92bec7431"
SRCREV_meta ?= "6128a9e47cd1aeb46b604469c17bff3eba8d5f93"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.8.git;branch=${KBRANCH};name=machine \
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.8.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.8.bb
index 8ed52ddbfc..1f026cf41b 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.8.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.8.bb
@@ -9,7 +9,7 @@ LINUX_VERSION ?= "4.8"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine ?= "707621a083512f037f749a711df3f4f1fb3ef842"
+SRCREV_machine ?= "67813e7efa3a4614e209c2f058d92ef9a636441a"
SRCREV_meta ?= "6128a9e47cd1aeb46b604469c17bff3eba8d5f93"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.8.bb b/meta/recipes-kernel/linux/linux-yocto_4.8.bb
index 71dc5ae35a..5e01abc8aa 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.8.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.8.bb
@@ -11,14 +11,14 @@ KBRANCH_qemux86 ?= "standard/base"
KBRANCH_qemux86-64 ?= "standard/base"
KBRANCH_qemumips64 ?= "standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "fc4881574f295bf2480f95d7c3e279ab32b44d8a"
-SRCREV_machine_qemuarm64 ?= "707621a083512f037f749a711df3f4f1fb3ef842"
-SRCREV_machine_qemumips ?= "013be1e230a0173677dfbfc081aea63fd7c58ec8"
-SRCREV_machine_qemuppc ?= "707621a083512f037f749a711df3f4f1fb3ef842"
-SRCREV_machine_qemux86 ?= "707621a083512f037f749a711df3f4f1fb3ef842"
-SRCREV_machine_qemux86-64 ?= "707621a083512f037f749a711df3f4f1fb3ef842"
-SRCREV_machine_qemumips64 ?= "7496d66804993fcfc569dd062f7e63a7490bc62f"
-SRCREV_machine ?= "707621a083512f037f749a711df3f4f1fb3ef842"
+SRCREV_machine_qemuarm ?= "f46e49344b4c66a6f0917c5a2e9a1d146176519d"
+SRCREV_machine_qemuarm64 ?= "67813e7efa3a4614e209c2f058d92ef9a636441a"
+SRCREV_machine_qemumips ?= "5a299402ae58d61429ab091f94748550efe45858"
+SRCREV_machine_qemuppc ?= "67813e7efa3a4614e209c2f058d92ef9a636441a"
+SRCREV_machine_qemux86 ?= "67813e7efa3a4614e209c2f058d92ef9a636441a"
+SRCREV_machine_qemux86-64 ?= "67813e7efa3a4614e209c2f058d92ef9a636441a"
+SRCREV_machine_qemumips64 ?= "674818dad577cdfc23c6c857aa2b769fc64e379c"
+SRCREV_machine ?= "67813e7efa3a4614e209c2f058d92ef9a636441a"
SRCREV_meta ?= "6128a9e47cd1aeb46b604469c17bff3eba8d5f93"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.8.git;name=machine;branch=${KBRANCH}; \