aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristophe PRIOUZEAU <christophe.priouzeau@st.com>2018-11-22 12:13:11 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-12-05 12:28:55 +0000
commit0fa7d99444763192914e798d8bc9dba1d9cdae42 (patch)
treefdce773a6a234d67c5f0f7777d9b75453b7e3302
parent1785be8220d8790ffdabfbc30e58244aae6400cc (diff)
downloadopenembedded-core-contrib-0fa7d99444763192914e798d8bc9dba1d9cdae42.tar.gz
openssl: correct bad path on package preprocess
In case of SDK generation, /usr/bin/ path are not correct and must be replaced by ${bindir}. Signed-off-by: Christophe Priouzeau <christophe.priouzeau@st.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-connectivity/openssl/openssl10_1.0.2q.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl10_1.0.2q.bb b/meta/recipes-connectivity/openssl/openssl10_1.0.2q.bb
index 8058b98677..6518dac076 100644
--- a/meta/recipes-connectivity/openssl/openssl10_1.0.2q.bb
+++ b/meta/recipes-connectivity/openssl/openssl10_1.0.2q.bb
@@ -353,8 +353,8 @@ openssl_package_preprocess () {
for file in `find ${PKGD} -name *.h -o -name *.pc -o -name *.so`; do
rm $file
done
- rm ${PKGD}/usr/bin/openssl
- rm ${PKGD}/usr/bin/c_rehash
- rmdir ${PKGD}/usr/bin
+ rm ${PKGD}${bindir}/openssl
+ rm ${PKGD}${bindir}/c_rehash
+ rmdir ${PKGD}${bindir}
}