aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Nyström <david.c.nystrom@gmail.com>2013-09-26 12:47:22 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-09-26 17:50:27 +0100
commitbe697e3cfa67fa61aa9ef2c9c0c75f4ed452414e (patch)
tree371ad0cc43d507a6c6def0573e1584ce05df28e0
parent5f6deb044226885912214532cebb1d871f03c53a (diff)
downloadopenembedded-core-contrib-be697e3cfa67fa61aa9ef2c9c0c75f4ed452414e.tar.gz
makedevs: Add device_table-minimal.txt to the nativesdk sysroot
Add an example device_table in the SDK under /usr/share/ Signed-off-by: David Nyström <david.nystrom@enea.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/makedevs/makedevs_1.0.0.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-devtools/makedevs/makedevs_1.0.0.bb b/meta/recipes-devtools/makedevs/makedevs_1.0.0.bb
index e6860f0c13..6e197b6e74 100644
--- a/meta/recipes-devtools/makedevs/makedevs_1.0.0.bb
+++ b/meta/recipes-devtools/makedevs/makedevs_1.0.0.bb
@@ -6,6 +6,8 @@ SRC_URI = "file://makedevs.c \
file://COPYING.patch"
PR = "r7"
+FILES_${PN}_append_class-nativesdk = " ${datadir}"
+
do_configure() {
install -m 0644 ${WORKDIR}/makedevs.c ${S}/
}
@@ -19,4 +21,9 @@ do_install() {
install -m 0755 ${S}/makedevs ${D}${base_sbindir}/makedevs
}
+do_install_append_class-nativesdk() {
+ install -d ${D}${datadir}
+ install -m 644 ${COREBASE}/meta/files/device_table-minimal.txt ${D}${datadir}/
+}
+
BBCLASSEXTEND = "native nativesdk"
85 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317