summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2022-07-10 22:16:50 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-07-12 12:52:48 +0100
commit1d63f8103cacd81dc631bbf87c612efff030c347 (patch)
tree92e2bf8e63310e8ebbc255e9c8889f0fe8af35f9
parent2a142b68b232ff7728f4eb945eea923c64e7ebd5 (diff)
downloadopenembedded-core-contrib-1d63f8103cacd81dc631bbf87c612efff030c347.tar.gz
linux-yocto/5.15: fix qemuppc buildpaths warning
Integrating the following commit(s) to linux-yocto/5.15: Author: Bruce Ashfield <bruce.ashfield@gmail.com> Date: Sun Jul 10 21:37:07 2022 -0400 vt/conmakehash: improve reproducibility The file generated by conmakehash capture the application path used to generate the file. While that can be informative, it varies based on where the kernel was built, as the full path is captured. We tweak the application to use a second input as the "capture name", and then modify the Makefile to pass the basename of the source, making it reproducible. This could be improved by using some sort of path mapping, or the application manipualing argv[1] itself, but for now this solves the reprodicibility issue. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_5.15.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_5.15.bb22
3 files changed, 15 insertions, 15 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_5.15.bb b/meta/recipes-kernel/linux/linux-yocto-rt_5.15.bb
index 96607c8a5e..9c869faa9d 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_5.15.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_5.15.bb
@@ -11,8 +11,8 @@ python () {
raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}
-SRCREV_machine ?= "6f3031c974b6c3bbbaaa15de66cbaecd21adf5db"
-SRCREV_meta ?= "263a2fb6fb2ed6f632d8d62fb46be2c51553b662"
+SRCREV_machine ?= "9179770f29198c123b02f1d7cd20fb08c71c0159"
+SRCREV_meta ?= "e532b0393413badf4f0df4b2337015efd8eae932"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.15;destsuffix=${KMETA}"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
index 5d0b0da209..b87e41776a 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
@@ -14,8 +14,8 @@ DEPENDS += "openssl-native util-linux-native"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine ?= "d6eb8944eeae98befa45b4d02a8fcc0d9048c7c7"
-SRCREV_meta ?= "263a2fb6fb2ed6f632d8d62fb46be2c51553b662"
+SRCREV_machine ?= "7dc6451b61e67818fe461b950a3450bf9d06067c"
+SRCREV_meta ?= "e532b0393413badf4f0df4b2337015efd8eae932"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_5.15.bb b/meta/recipes-kernel/linux/linux-yocto_5.15.bb
index 054bfc117a..e09faaecdb 100644
--- a/meta/recipes-kernel/linux/linux-yocto_5.15.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_5.15.bb
@@ -13,17 +13,17 @@ KBRANCH:qemux86 ?= "v5.15/standard/base"
KBRANCH:qemux86-64 ?= "v5.15/standard/base"
KBRANCH:qemumips64 ?= "v5.15/standard/mti-malta64"
-SRCREV_machine:qemuarm ?= "9c053034b8860590006f7366a0ba28a3857e7c9a"
-SRCREV_machine:qemuarm64 ?= "f7cb33fbf883c3490fd33fe1aa3833d8721bfba5"
-SRCREV_machine:qemumips ?= "f4a865ffde7375a6abbf7aaad67307ea0bc60605"
-SRCREV_machine:qemuppc ?= "ee8fa730ad56949954c321ee068bbee6fc44dbdb"
-SRCREV_machine:qemuriscv64 ?= "b54384a7eba92a04eac7c415dbe7aa9e7079b2fc"
-SRCREV_machine:qemuriscv32 ?= "b54384a7eba92a04eac7c415dbe7aa9e7079b2fc"
-SRCREV_machine:qemux86 ?= "b54384a7eba92a04eac7c415dbe7aa9e7079b2fc"
-SRCREV_machine:qemux86-64 ?= "b54384a7eba92a04eac7c415dbe7aa9e7079b2fc"
-SRCREV_machine:qemumips64 ?= "98c315f0ebd297e1cb6f1a9aa6bf16a02c1e4ec5"
-SRCREV_machine ?= "b54384a7eba92a04eac7c415dbe7aa9e7079b2fc"
-SRCREV_meta ?= "263a2fb6fb2ed6f632d8d62fb46be2c51553b662"
+SRCREV_machine:qemuarm ?= "51fc1677b3378d04bf6bc59f632d80c8a21e54fe"
+SRCREV_machine:qemuarm64 ?= "5c9319fd04d643d55836b94f7eeb4dd7561ea197"
+SRCREV_machine:qemumips ?= "78b65359d44c9ae535388dfc8bf06eb8dc8764dc"
+SRCREV_machine:qemuppc ?= "dd1a7ce7eb8274e72507d634d9239109fdbebb85"
+SRCREV_machine:qemuriscv64 ?= "0f586f4ee8adacac79b64d1f3d47799a5eb7fbea"
+SRCREV_machine:qemuriscv32 ?= "0f586f4ee8adacac79b64d1f3d47799a5eb7fbea"
+SRCREV_machine:qemux86 ?= "0f586f4ee8adacac79b64d1f3d47799a5eb7fbea"
+SRCREV_machine:qemux86-64 ?= "0f586f4ee8adacac79b64d1f3d47799a5eb7fbea"
+SRCREV_machine:qemumips64 ?= "a6f8486df096f727ec6233a152947d9bf26202bb"
+SRCREV_machine ?= "0f586f4ee8adacac79b64d1f3d47799a5eb7fbea"
+SRCREV_meta ?= "e532b0393413badf4f0df4b2337015efd8eae932"
# set your preferred provider of linux-yocto to 'linux-yocto-upstream', and you'll
# get the <version>/base branch, which is pure upstream -stable, and the same