aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2016-05-18 13:40:38 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-21 22:21:29 +0100
commita3084bd681f67b28b4e4b44ba0c6a281800f719d (patch)
tree78c7c894eaffd750e93af1df0f83f0a582f1adc6
parent32e9ef3089de6cf2da3a2b53579e5e015dfe6c12 (diff)
downloadopenembedded-core-contrib-a3084bd681f67b28b4e4b44ba0c6a281800f719d.tar.gz
weston: Add PACKAGECONFIG option for 'clients'
This allow Weston to be build without the clients. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-graphics/wayland/weston_1.10.0.bb7
1 files changed, 3 insertions, 4 deletions
diff --git a/meta/recipes-graphics/wayland/weston_1.10.0.bb b/meta/recipes-graphics/wayland/weston_1.10.0.bb
index d3e2607110..16e961de3f 100644
--- a/meta/recipes-graphics/wayland/weston_1.10.0.bb
+++ b/meta/recipes-graphics/wayland/weston_1.10.0.bb
@@ -24,9 +24,6 @@ DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0 jpeg"
DEPENDS += "wayland wayland-protocols libinput virtual/egl pango wayland-native"
EXTRA_OECONF = "--enable-setuid-install \
- --enable-simple-clients \
- --enable-clients \
- --enable-demo-clients-install \
--disable-rpi-compositor \
--disable-rdp-compositor \
WAYLAND_PROTOCOLS_SYSROOT_DIR=${STAGING_DIR}/${MACHINE} \
@@ -43,7 +40,7 @@ PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'kms fbdev
${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'launch', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)} \
- "
+ clients"
#
# Compositor choices
#
@@ -77,6 +74,8 @@ PACKAGECONFIG[systemd] = "--enable-systemd-login,--disable-systemd-login,systemd
PACKAGECONFIG[xwayland] = "--enable-xwayland,--disable-xwayland,libxcb libxcursor cairo"
# colord CMS support
PACKAGECONFIG[colord] = "--enable-colord,--disable-colord,colord"
+# Clients support
+PACKAGECONFIG[clients] = "--enable-clients --enable-simple-clients --enable-demo-clients-install,--disable-clients --disable-simple-clients"
do_install_append() {
# Weston doesn't need the .la files to load modules, so wipe them